HDU1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 275474 Accepted Submission(s): 53177

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

大数计算用字符串写的 虽然是水题但是很坑的。。

#include <iostream>
#include <cstdio>
#include <string.h>
#define B 1
#define A 0
using namespace std;
int main()
{
    int ncase;
    while(scanf("%d",&ncase)!=EOF)
    {
        int mark;
        for(int m=1;m<=ncase;m++)
        {
            char a[1005];
            char b[1005];
            int  c[1005];
            char tran[1005];
            scanf("%s",a);
            scanf("%s",b);
            memset(c,0,sizeof(c));
            if(m==1)
            {
                cout<<"Case "<<m<<":"<<endl;
                cout<<a<<" + "<<b<<" = ";
            }
            else
            {
                cout<<endl;
                cout<<"Case "<<m<<":"<<endl;
                cout<<a<<" + "<<b<<" = ";
            }

            int lena=strlen(a);
            int lenb=strlen(b);
            int max,min;
            if(lena>lenb)
            {
                int m=0;
                for(int i=lena-lenb;i<=lena-1;i++)
                {
                    tran[i]=b[m];
                    m++;
                }
                for(int i=0;i<=lena-lenb-1;i++)
                {
                    tran[i]='0';
                }
                memcpy(b,tran,sizeof(a));
                max=lena;
                min=lenb;
            }
            else
            {
                int m=0;
                for(int i=lenb-lena;i<=lenb-1;i++)
                {
                    tran[i]=a[m];
                    m++;
                }
                for(int i=0;i<=lenb-lena-1;i++)
                {
                    tran[i]='0';
                }
                memcpy(a,tran,sizeof(a));
                max=lenb;
                min=lena;

            }

            for(int i=max-1;i>0;i--)
            {
                c[i]=a[i]-'0'+b[i]-'0'+c[i];
                if(c[i]>9)
                {
                    c[i-1]++;
                    c[i]=c[i]-10;
                }

            }

            if((a[0]-'0'+b[0]-'0'+c[0])>9)
            {
                cout<<"1";
                c[0]=a[0]-'0'+b[0]-'0'-10+c[0];
            }
            else
            {
                c[0]=a[0]-'0'+b[0]-'0'+c[0];
            }

            for(int i=0;i<=max-1;i++)
            {
                cout<<c[i];
            }
            cout<<endl;

        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值