HDU1256

画8

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4994 Accepted Submission(s): 2167

Problem Description
谁画8画的好,画的快,今后就发的快,学业发达,事业发达,祝大家发,发,发.

Input
输入的第一行为一个整数N,表示后面有N组数据.
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度.

Output
画横线总是一个字符粗,竖线随着总高度每增长6而增加1个字符宽.当总高度从5增加到6时,其竖线宽度从1增长到2.下圈高度不小于上圈高度,但应尽量接近上圈高度,且下圈的内径呈正方形.
每画一个”8”应空一行,但最前和最后都无空行.

Sample Input
2
A 7
B 8

Sample Output
AA
AA AA
AA AA
AA
AA AA
AA AA
AA

BBB
BB BB
BB BB
BBB
BB BB
BB BB
BB BB
BBB

大一刚进来的时候参加了学院的一次比赛,里面出了这道题,当时题目都没读懂,主要问题是下面那个葫芦要是正方形这点没理解好,现在终于AC了,纪念一下。

#include "iostream"
#include "cstring"
#include "iostream"
#include "string.h"

using namespace std;


void draw_parti(char pen,int pen_width, int width)
{
    for (int i = 1; i <= pen_width; i++)
        printf(" ");
    for (int i = 1; i <= width; i++)
        printf("%c", pen);
}

void draw_partii(char pen, int pen_width, int width,int flag)
{
    for (int i = 1; i <= flag; i++)
    {
        for (int j = 1; j <= pen_width; j++)
            printf("%c",pen);
        for (int j = 1; j <= width; j++)
            printf(" ");
        for (int j = 1; j <= pen_width; j++)
            printf("%c", pen);
        printf("\n");
    }
}
int main()
{
    char pen;
    int ncase;
    while (scanf("%d", &ncase) != EOF)
    {
        while (ncase--)
        {
            getchar();
            scanf("%c", &pen);
            int height;
            scanf("%d", &height);
            int pen_width = height / 6;
            pen_width += 1;
            int up, down;
            int width;
            if (height % 2 == 1)
            {
                up = down = (height - 3) / 2;
            }
            else
            {
                up = (height - 3 - 1)/2;
                down = (height - 3 + 1) / 2;
            }
            width = down;

            draw_parti(pen, pen_width, width);
            printf("\n");
            draw_partii(pen, pen_width, width,up);
            draw_parti(pen, pen_width, width);
            printf("\n");
            draw_partii(pen, pen_width, width, down);
            draw_parti(pen, pen_width, width);
            if (ncase != 0)
                printf("\n\n");
            else
                printf("\n");
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值