HDU1513 Palindrome(LCS+滚动数组)

Palindrome

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4960 Accepted Submission(s): 1703

Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input
5
Ab3bd

Sample Output
2

Source
IOI 2000

Recommend
linle | We have carefully selected several similar problems for you: 1505 1074 1025 1510 1501

题意:给你一个字符串问你最少添加多少个字符可以使其构成回文串。
将输入串反转一下,再和原串跑一下LCS,再用总的串长-LCS的结果就是答案。这里有个问题是如果你直接开5000*5000会爆内存,所以必须用滚动数组搞一搞。

#include <cstring>
#include <string.h>
#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
    char s1[5005];
    char s2[5005];
    long long dp[2][5005];
    int n;
    while(scanf("%d %s",&n,s1+1)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        long long len=strlen(s1+1);
        for(int i=1;i<=len;i++)
        {
            s2[len+1-i]=s1[i];
        }
        long long mmax=0;
        for(int i=1;i<=len;i++)
        {
            for(int j=1;j<=len;j++)
            {
                if(s1[i]==s2[j])
                    dp[i%2][j]=dp[(i-1)%2][j-1]+1;
                else
                    dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
                //if(mmax<dp[i%2][j])
                //    mmax=dp[i%2][j];
            }
        }
        printf("%lld\n",len-dp[len%2][len]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值