POJ 2411 Mondriaan's Dream ( 状压DP )

Mondriaan’s Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 15491 Accepted: 8936
Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0
Sample Output

1
0
1
2
3
5
144
51205
Source

Ulm Local 2000

有个一个n*m的地面,给你1*2规格的地砖,问有多少种方案可以把地面铺满

如果i-1行的出发状态某处未放,必然要在i行放一个竖的方块,所以对上一行状态按位取反之后的状态就是放置了竖方块的状态。
然后用搜索扫一道在i行放横着的方块的所有可能,并且把这些状态累加上i-1的出发状态的方法数,如果该方法数为0,直接continue。

#include "cstring"
#include "string.h"
#include "iostream"
#include "cstdio"
using namespace std;
int h,w;

long long dp[15][(1<<11)+5];

void dfs(int row,int column,int status,long long sum)
{
    if(column>=w)
    {
        dp[row][status]+=sum;
        return;
    }
    dfs(row,column+1,status,sum);
    if(column<=w-2&& !(status&(1<<column)) && !(status&(1<<(column+1))) )
    {
        dfs(row,column+2,status|1<<column|1<<(column+1),sum);
    }
}

int main()
{
    while(scanf("%d%d",&h,&w)&&h!=0)
    {
        memset(dp,0,sizeof(dp));
        dfs(1,0,0,1);
        int top = 1 << w;
        for(int i=2;i<=h;i++)
        {
            for(int j=0;j<(1<<w);j++)
            {
                if(dp[i-1][j]==0)
                    continue;
                //dfs(i,0,~j&(top-1),dp[i-1][j]);
                dfs(i,0,~j&(top-1),dp[i-1][j]);
            }
        }
        printf("%lld\n",dp[h][top-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值