POJ 1155 TELE (树形DP)

TELE
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4931 Accepted: 2715
Description

A TV-network plans to broadcast an important football match. Their network of transmitters and users can be represented as a tree. The root of the tree is a transmitter that emits the football match, the leaves of the tree are the potential users and other vertices in the tree are relays (transmitters).
The price of transmission of a signal from one transmitter to another or to the user is given. A price of the entire broadcast is the sum of prices of all individual signal transmissions.
Every user is ready to pay a certain amount of money to watch the match and the TV-network then decides whether or not to provide the user with the signal.
Write a program that will find the maximal number of users able to watch the match so that the TV-network’s doesn’t lose money from broadcasting the match.
Input

The first line of the input file contains two integers N and M, 2 <= N <= 3000, 1 <= M <= N-1, the number of vertices in the tree and the number of potential users.
The root of the tree is marked with the number 1, while other transmitters are numbered 2 to N-M and potential users are numbered N-M+1 to N.
The following N-M lines contain data about the transmitters in the following form:
K A1 C1 A2 C2 … AK CK
Means that a transmitter transmits the signal to K transmitters or users, every one of them described by the pair of numbers A and C, the transmitter or user’s number and the cost of transmitting the signal to them.
The last line contains the data about users, containing M integers representing respectively the price every one of them is willing to pay to watch the match.
Output

The first and the only line of the output file should contain the maximal number of users described in the above text.
Sample Input

9 6
3 2 2 3 2 9 3
2 4 2 5 2
3 6 2 7 2 8 2
4 3 3 3 1 1
Sample Output

5
Source

Croatia OI 2002 Final Exam - Second Day

电视台从根节点1,通过许多的中继器将信号传递给用户,用户是叶子节点,每个客户都愿意付一定的价钱来看节目。电视台传送信号是有花费的,问电视台如何在不亏钱的情况下覆盖尽量多的客户。
经典的树形DP。dp[i][j]的含义是i节点在覆盖j个客户的情况下最多能赚多少钱。有个需要注意的问题是dp迭代更新的时候不能直接循环到最大人数这样会t,应该循环到当前节点的子树能覆盖的最多客户数,否则会TLE。

#include "cstring"
#include "iostream"
#include "cstdio"
#include "string.h"
#include "cmath"
#define MAX 3005
using namespace std;
int n,m;
struct edge
{
    int to;
    int next;
    int cost;
}edge[MAX*2];
int dp[MAX][MAX];
int head[MAX];
int len=0;
int num[MAX];
void addEdge(int a,int b,int cost)
{
    edge[len].to=b;
    edge[len].cost=cost;
    edge[len].next=head[a];
    head[a]=len++;
}
void init()
{
    //memset(dp,0xc0,sizeof(dp));
    memset(head,-1,sizeof(head));
    len=0;
}
void dfs(int root,int last)
{
    for(int i=head[root];i!=-1;i=edge[i].next)
    {
        int son=edge[i].to;
        if(son==last)
            continue;
        dfs(son,root);
        num[root] += num[son];
        for(int j=num[root];j>=0;j--)
        {
            for(int k=0;j-k>=0;k++)
            {
                dp[root][j]=max(dp[root][j],dp[root][j-k]+dp[son][k]-edge[i].cost);
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(int i=1;i<=n-m;i++)
        {
            int cnt;
            num[i]=0;
            scanf("%d",&cnt);
            while(cnt--)
            {
                int a,c;
                scanf("%d%d",&a,&c);
                addEdge(i,a,c);
                addEdge(a,i,c);
            }
        }
        for( int i = 1; i <= n; i++ )
            for( int j = 1; j <= m; j++ )
                dp[i][j] = -99999999;
        for(int i=n-m+1;i<=n;i++)
        {
            num[i]=1;
            scanf("%d",&dp[i][1]);
        }
        dfs(1,0);
        int ans=0;
        for(int i=1;i<=m;i++)
        {
            if(dp[1][i]>=0)
                ans=i;
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值