HDU 5883 The Best Path (欧拉通路) 2016 ACM/ICPC Asia Regional Qingdao Online

The Best Path

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 502 Accepted Submission(s): 207

Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,…,an) for each lake. If the path she finds is P0→P1→…→Pt, the lucky number of this trip would be aP0XORaP1XOR…XORaPt. She want to make this number as large as possible. Can you help her?

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000), as described above. The i-th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i-th lake.

The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi.

Output
For each test cases, output the largest lucky number. If it dose not have any path, output “Impossible”.

Sample Input
2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4

Sample Output
2
Impossible

Source
2016 ACM/ICPC Asia Regional Qingdao Online

Recommend
wange2014 | We have carefully selected several similar problems for you: 5901 5900 5899 5898 5897

无向图中通过一个点次数等于该点的度/2向上取整。
无向连通图含有欧拉通路,当且仅当其有0个活两个奇数度的点。
知道这两个就可以敲了。无非就是统计度的问题。

#include "cstring"
#include "string.h"
#include "iostream"
#include "cstdio"
#include "cmath"
using namespace std;
int value[100005];
int degree_cnt[100005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        memset(degree_cnt,0,sizeof(degree_cnt));
        for(int i=1;i<=n;i++)
            scanf("%d",&value[i]);
        for(int i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            degree_cnt[a]++;
            degree_cnt[b]++;
        }
        int odd_cnt=0;
        for(int i=1;i<=n;i++)
        {
            if(degree_cnt[i]&1)
                odd_cnt++;
        }
        if(odd_cnt!=0&&odd_cnt!=2)
        {
            printf("Impossible\n");
            continue;
        }
        int ans=0;
        if(odd_cnt==0)
        {
            int temp=0;
            for(int i=1;i<=n;i++)
                temp^=value[i];
            for(int i=1;i<=n;i++)
            {
                temp^=value[i];
                ans=max(ans,temp);
            }
            printf("%d\n",ans);
            continue;
        }
        for(int i=1;i<=n;i++)
        {
            degree_cnt[i]=ceil(degree_cnt[i]*1.0/2.0);
            if(degree_cnt[i]&1)
                ans^=value[i];
        }
        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值