Appoint description:
Description
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)
2=a
2+2ab+b
2). So you decide to waste your time with drawing modern art instead.
Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:
Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:
Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input
5 4 1 1 0 0
Sample Output
126 2
题意:给出一个n*m 的方格,问从左下方走到右上方共有多少种走法。
思路:其实你不管怎么走,你走的总步数肯定是n+m步,选取了横向的n步,那么纵向的也就确定了,所以结果为n+m步里取出n步的所有组合数。
- #include <stdio.h>
- #include <math.h>
- #include <string.h>
- #include <stdlib.h>
- #include <iostream>
- #include <sstream>
- #include <algorithm>
- #include <set>
- #include <queue>
- #include <stack>
- #include <map>
- using namespace std;
- typedef long long LL;
- const int inf=0x3f3f3f3f;
- const double eps=1e-10;
- const double pi= acos(-1.0);
- const int MAXN=31269;
- //下面是一个O(n)的求组合数的方法。
- LL C(LL n,LL m)
- {
- if(m>n/2) m=n-m;
- LL a=1,b=1;
- for(int i=1;i<=m;i++){
- a*=n-i+1;
- b*=i;
- if(a%b==0){
- a/=b;
- b=1;
- }
- }
- return a/b;
- }
- int main()
- {
- LL n,m;
- while(~scanf("%lld %lld",&n,&m)){
- if(!n&&!m) break;
- printf("%lld\n",C(n+m,n));
- }
- return 0;
- }