poj 2785 二分或者hash

2 篇文章 0 订阅
1 篇文章 0 订阅
4 Values whose Sum is 0
Time Limit: 15000MS
Memory Limit: 228000K
Total Submissions: 18896
Accepted: 5619
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30). 

这题ppt里有思路。枚举前两个数的和,在后两个数的和中找符合的。

第一次是用二分做的,一次AC

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[4000],b[4000],c[4000],d[4000],sum1[16000000],sum2[16000000];
int main()
{
    int n,i,k,l,r,mid,midl,midr,cnt,j;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
    }
    k=0;
    for(i=0;i<n;i++)
    {
        for(j=0;j<n;j++)
        {
            sum1[k]=a[i]+b[j];
            sum2[k]=c[i]+d[j];
            k++;
        }
    }
    sort(sum2,sum2+k);
    cnt=0;
    for(i=0;i<k;i++)
    {
        l=0;
        r=k-1;
        while(l<=r)
        {
            mid=(l+r)/2;
            if(sum2[mid]+sum1[i]<0)
            {
                l=mid+1;
            }
            else if(sum2[mid]+sum1[i]>0)
            {
                r=mid-1;
            }
            else
            {
                midl=midr=mid;
                while(sum2[midr]+sum1[i]==0)
                {
                    midr++;
                    if(midr==k)break;
                }
                while(sum2[midl]+sum1[i]==0)
                {
                    midl--;
                    if(midl==-1)break;
                }
                cnt+=midr-midl-1;
                break;
            }
        }
    }
    printf("%d\n",cnt);
    return 0;
}

hash不是我写的,只是帮别人看为什么WA,顺便学了一点。。。WA的原因是存进链表中的数存成绝对值了改完之后就超时,是因为每算一个和就new了一次,速度比较慢。。后来就改成需要的时候再用,可以省些时间

#include <iostream>
#include<stdio.h>
using namespace std;
const int MOD=10000007;
struct node
{
  int data,num;
  node *next;
};
node *aa[MOD],*t,*p;
int sum;
void find(int m)
{
  int val=(m>0?m:-m)%MOD;
  t=aa[val];
  while(t!=NULL)
  {
    if(t->data==m)
    {
      sum+=t->num;
      break;
    }
    t=t->next;
  }
}
int main()
{
  int i,j,n,m,a[4005],b[4005],c[4005],d[4005];
    scanf("%d",&n);
        for(i=0;i<MOD;i++) aa[i]=NULL;
    for(i=0;i<n;i++) scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
    for(i=0;i<n;i++)
      for(j=0;j<n;j++)
      {
        m=a[i]+b[j];
        int tmp=(m>0?m:-m)%MOD;
        if(aa[tmp]==NULL)
        {
            p=new node;
            p->data=m;
            p->next=NULL;
            p->num=1;
            aa[tmp]=p;
            continue;
        }
        t=aa[tmp];
        while(true)
        {
          if(t->data==m)
          {
            t->num++;
            break;
          }
          if(t->next==NULL)
          {
              p=new node;
              p->data=m;
              p->next=NULL;
              p->num=1;
              t->next=p;
              break;
          }
          t=t->next;
        }
      }
    sum=0;
    for(i=0;i<n;i++)
      for(j=0;j<n;j++)
      {
        m=-c[i]-d[j];
        find(m);
      }
    printf("%d\n",sum);
}
还有太多东西不懂。。然而还是浪费时间。。。

有的时候有些事情真的不知道该怎么办。。。总之还是努力过的开心吧==


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值