1020 Tree Traversals (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:

给出一个二叉树的后序遍历和中序遍历序列,要求你求出该二叉树的层序遍历序列。

解题思路:

首先需要根据后序遍历序列以及中序遍历序列确定这棵唯一的二叉树,之后采用BFS遍历输出即可。

后序遍历和中序遍历确定二叉树:

(摘自胡凡算法笔记9.2.4)

假设后序遍历序列存储在post数组中,区间为[pL,pR],根据其性质可知,最后一个元素为根节点;在中序遍历序列in数组(区间[iL,iR])中查找该元素,可将中序遍历序列分为左右子序列,即确定该根节点的左右子树;

递归以上步骤直到左右子树均为空,即可确定一棵二叉树。

代码如下: 

#include<iostream>
#include<queue>
using namespace std;
struct Node{
	int data;
	Node* left;
	Node* right;
};
int n,post[30],in[30];

Node* create(int pL,int pR,int iL,int iR){
	if(pL > pR)
		return NULL;
	Node* root = new Node;
	root->data = post[pR];
	int temp_root;
	for(int i = iL;i <= iR ; i ++)
		if(in[i] == root->data)
		{
			temp_root = i;
			break;
		}	
	int left_count = temp_root - iL;
	root->left = create(pL,pL+left_count-1,iL,temp_root-1);
	root->right = create(pL+left_count,pR-1,temp_root+1,iR);
	return root;
}
void bfs(Node* tree){
	queue<Node*> q;
	q.push(tree);
	int sum = 0;  //记录输出了多少个数 
	while(!q.empty()){
		if(sum > 0)
			printf(" ");
		Node* now = q.front();
		printf("%d",now->data);
		q.pop();
		sum++;
		if(now->left)
			q.push(now->left);
		if(now->right)
			q.push(now->right);
	}
}

int main(){
	scanf("%d",&n);
	for(int i = 0 ; i < n ; i ++)
		scanf("%d",&post[i]);
	for(int i = 0 ; i < n ; i ++)
		scanf("%d",&in[i]);
	Node* tree = create(0,n-1,0,n-1);//创建二叉树 
	bfs(tree);//层序遍历 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值