PAT-A1020 Tree Traversals 题目内容及题解

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意

题目给出某二叉树的后序和中序遍历,求其层序遍历。

解题思路

  1. 由二叉树后序和中序遍历确定二叉树;
  2. 对二叉树进行层序遍历并输出,返回0值。

代码

#include<stdio.h>
#include<stdlib.h>
#define maxn 35

typedef struct TreeNode{
    int data;
    struct TreeNode *lchild,*rchild;
}Node;

int post[maxn],in[maxn],N;

void Init(){
    int i;
    scanf("%d",&N);
    for(i=0;i<N;i++){
        scanf("%d",&post[i]);
    }
    for(i=0;i<N;i++){
        scanf("%d",&in[i]);
    }
}

Node* Create(postL,postR,inL,inR){
    int numL,k=inL;
    if(postL>postR){
        return NULL;
    }
    Node* root=(Node*)malloc(sizeof(Node));
    root->data=post[postR];
    root->lchild=NULL;
    root->rchild=NULL;
    while(in[k]!=root->data){
        k++;
    }
    numL=k-inL;
    root->lchild=Create(postL,postL+numL-1,inL,k-1);
    root->rchild=Create(postL+numL,postR-1,k+1,inR);
    return root;
}

void Layer(Node* root){
    Node *Queue[maxn],*T;
    int front=0,rear=0,k=0;
    Queue[rear++]=root;
    while(front<rear){
        T=Queue[front++];
        printf("%d",T->data);
        if(++k==N){
            printf("\n");
        }else{
            printf(" ");
        }
        if(T->lchild){
            Queue[rear++]=T->lchild;
        }
        if(T->rchild){
            Queue[rear++]=T->rchild;
        }
    }
    return;
}

int main(){
    Node* root=NULL;
    Init();
    root=Create(0,N-1,0,N-1);
    Layer(root);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值