POJ-1700-最快渡河(贪心)

11 篇文章 0 订阅
3 篇文章 0 订阅

Crossing River POJ - 1700

A group of N people wishes to go across a river with only one boat,
which can at most carry two persons. Therefore some sort of shuttle
arrangement must be arranged in order to row the boat back and forth
so that all people may cross. Each person has a different rowing
speed; the speed of a couple is determined by the speed of the slower
one. Your job is to determine a strategy that minimizes the time for
these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <=
20), the number of test cases. Then T cases follow. The first line of
each case contains N, and the second line contains N integers giving
the time for each people to cross the river. Each case is preceded by
a blank line. There won’t be more than 1000 people and nobody takes
more than 100 seconds to cross.

Ouput

For each test case, print a line containing the total number of
seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17
//POJ-1700
//贪心--快速渡河
#include <iostream>
#include <algorithm>
using namespace std;

void crossRiver(int n, int speed[]) {
	int ans = 0;//结果
	int left = n;
	while (left > 0) {
		if (n == 1) {
			ans += speed[0];
			break;
		}
		else if (left == 2) {
			ans += speed[1];
			break;
		}
		else if (left == 3) {
			ans += speed[0] + speed[1] + speed[2];
			break;
		}
		else {
			//把最慢的两个送过去,这里有两种策略
			int s1, s2;
			//1.
			s1 = speed[left - 1] + speed[0] + speed[left - 2] + speed[0];
			//2.
			s2 = speed[1] + speed[0] + speed[left - 1] + speed[1];
			ans += min(s1, s2);
			left -= 2;
		}
	}
	cout << ans << endl;
}

int main() {
	int t;
	cin >> t;
	while (t--) {
		int n;
		cin >> n;//n个人数
		int *speed = new int[n];
		for (int i = 0; i < n; i++) {
			cin >> speed[i];
		}
		crossRiver(n, speed);
	}
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值