快速渡河

快速渡河(贪心)

/*
A group of N people wishes to go across a river with only one boat, which can at most carry two persons.
Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross.
Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one.
Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases.
Then T cases follow.
The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river.
Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input
1
4
1 2 5 10
Sample Output
17
*/

package _90贪心;

import java.util.Arrays;
import java.util.Scanner;

/*1是组数据
 * 4   四个入         1和2过去        2秒  
 * 1 2 5 10 四个人的速度    1回来    花1秒       5和10 过去花10秒  2回来花两秒    1和2过去花2秒
 * 17     输出最优解;
 */
//a b c d   == a+3b+d //分组
//a b c d   ==2a+b+c+d  快的带
public class b快速渡河 {
public static void main(String[] args) {
	 Scanner in=new Scanner(System.in) ;
		 int T =in.nextInt();
	   for(int i=0;i<T;i++) {
		 int n=in.nextInt();
		 int[]speed=new int[n];//可以放在一个循环里
	   for(int j=0;j<n;j++) {
			 speed[j]=in.nextInt();
		 }
	   Arrays.sort(speed);
	   f(n,speed);
	 }		 
}
private static void f(int n, int[] speed) {
	 int left=n;//有多少人
	 int ans=0;//记时间
	 while(left>0) {
		 if(left==1) {
			 ans+=speed[0];
			 break;
		 }else if(left==2) {
			 ans+=speed[1];
			 break;
		 }else if(left==3) {
			 ans+=speed[2]+speed[0]+speed[1];
			 break;
		 }else {
	 //1,2出发,1返回,最后两名出发,2返回
	 int s1=speed[1]+speed[0]+speed[left-1]+speed[1];//2b+a+d
	  //1,3出发,1返回,1,4出发,1返回,1,2过河
	 int s2=speed[left-1]+speed[left-2]+2*speed[0];//c+d+2a
	   ans +=Math.min(s1, s2);
	   left-=2;;//左侧是渡河的起点,left代表左侧的剩余人数
		 }
	 }
	 System.out.println(ans);
}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

金石不渝

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值