Emergency

1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

本题主要的思路是运用dijkstra寻找最短路径,不同的是在路径选择过程中增加了新的条件,不仅仅要求路径最短而且还需要救援队伍最多。

diskstra的主要思想:

将图的所有节点分为两个集合S和G。S是包含原点的已求得最短路径的所有节点;G是剩余的未寻找到最短路径节点。

假设v是原点,k是集合G中距离原点v最近的一个节点,u是集合G中的另一个节点。

此时v到k的当前路径必定是最短路径,我们将k加入集合S,那么当k加入集合S后,原点v经过S中的节点到达u的当前最短路径必定是v->u或者v->k->u其中的一条,更新原点v到达u的距离。

#include <limits.h>头文件可以使用其中所有类型的边界值:

INT_MAX:int类型的最大值

#include <iostream>
#include <vector>
#include <limits.h>

using namespace std;

void dijkstra(int source, int destination);
int addClosestNode();
void updateNode(int index);

vector<int> city;
vector<vector<int> > road;
vector<bool> visited;
vector<int> length,totalTeams,prevNode,paths;
int numOfCities;

int main() {
	int numOfRoads,source,destination;
	cin >> numOfCities >> numOfRoads >> source >> destination;

	road.resize(numOfCities, vector<int>(numOfCities, 0));
	city.resize(numOfCities, 0);
	visited.resize(numOfCities, false);
	length.resize(numOfCities, INT_MAX);
	totalTeams.resize(numOfCities, 0);
	prevNode.resize(numOfCities, -1);
	paths.resize(numOfCities, 0);
	for (int i = 0; i < numOfCities; i++)
	{
		cin >> city[i];
	}
	int start, end, dist;
	for (int i = 0; i < numOfRoads; i++)
	{
		cin >> start >> end >> dist;
		road[start][end] = dist;
		road[end][start] = dist;
	}
	
	dijkstra(source,destination);

	cout << paths[destination] << " " << totalTeams[destination];
	//system("pause");
	return 0;
}

void dijkstra(int source, int destination) {
	length[source] = 0;
	paths[source] = 1;
	totalTeams[source] = city[source];

	int index;
	for (int i = 0; i < numOfCities; i++)
	{
		index = addClosestNode();
		if (index == destination) {
			return;
		}
		updateNode(index);
	}
}

int addClosestNode() {
	int closest = -1;
	for (int i = 0; i < numOfCities; i++)
	{
		if (!visited[i] && (closest<0 || length[i] < length[closest]) ) {
			closest = i;
		}
	}
	visited[closest] = true;
	
	return closest;
}

void updateNode(int index) {
	for (int i = 0; i < numOfCities; i++)
	{
		if (!visited[i] && road[index][i]!=0) {
			if (length[index] + road[index][i] < length[i])
			{
				length[i] = length[index] + road[index][i];
				paths[i] = paths[index];
				totalTeams[i] = totalTeams[index] + city[i];
			}
			else if (length[index] + road[index][i] == length[i])
			{
				paths[i] += paths[index];
				if (totalTeams[i] < totalTeams[index] + city[i]) {
					totalTeams[i] = totalTeams[index] + city[i];
				}
			}
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值