PAT乙级练习题B1004.成绩排名

题目描述

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
… … …
第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112

代码

这里使用结构体struct和输入输出运算符重载;

#include<iostream>
#include<string>
#include<vector>
using namespace std;

struct student {
    friend ostream &operator<<(ostream &os, const student &item);
    friend ostream &operator>>(ostream &is, student &item);
    string name;
    string ID;
    unsigned int grade;
};
ostream &operator<<(ostream &os, const student &item)
{
    os << item.name << " " << item.ID;
    return os;
}

istream &operator>>(istream &is, student &item) 
{
    is >> item.name >> item.ID >> item.grade;
    return is;
}

int main()
{
    int n;
    vector<student> stud_class;
    cin >> n;
    int max, min;
    for (int i = 0; i < n; ++i)
    {
        student stud;
        cin >> stud;
        stud_class.push_back(stud);
        if (i == 0)
        {
            max = stud.grade;
            min = stud.grade;
            continue;
        }
        if (max < stud.grade)
            max = stud.grade;
        if (min > stud.grade)
            min = stud.grade;
    }

    for (auto &it : stud_class)
    {
        if (it.grade == max)
            cout << it << endl;
    }
    for (auto &it : stud_class)
    {
        if (it.grade == min)
            cout << it << endl;
    }
    system("pause");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值