PAT甲级练习题A1038. Recover the Smallest Number (30)

题目描述

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

题目解析

使用string储存数字,然后排序,
这里我自己写了一个递归的判断函数;
参考 @浅蓝 可以使用一个简单的判断条件 a+b

代码

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;

bool my_comp(string a, string b)
{
    if (a.size() < b.size() && a == b.substr(0, a.size()))
    {
        return my_comp(a, b.substr(a.size(), b.size() - a.size()));
    }
    else if (a.size() > b.size() && b == a.substr(0, b.size()))
    {
        return my_comp(a.substr(b.size(), a.size() - b.size()), b);
    }
    else
        return a < b;
}

int main()
{
    int N;
    cin >> N;
    vector<string> num(N);
    for (int i = 0; i < N; ++i)
    {
        cin >> num[i];
    }
    sort(num.begin(), num.end(),my_comp);
    string sum;

    for (int i = 0; i < num.size(); ++i)
    {
        sum+= num[i];
    }
    auto it = sum.find_first_not_of('0');
    if (it == sum.npos)
        cout << 0 << endl;
    else
        cout << sum.substr(it, sum.size() - it) << endl;
    system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值