HDU 1008 Elevator

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1008


解析:

题目的意思相对比较简单,

电梯上一层需要6秒,下一层需要4秒,每次电梯停靠5秒

初始的时候,电梯在0层,结束后不需要回到0层。


样例:

Sample Input
  
  
1 2 3 2 3 1 0
Sample Output
  
  
17 41

我们从样例可以看出来

第一个:(2-0)*6+5 = 17

第二个:(3-2)*4+5+(3-2)*6+5+(3-1)*6+5 = 41

我个人理解为在最后一层也得停留5秒吧~


代码:

#include <iostream>
#include <iomanip>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;

int main(){
    int N;
    while(cin >> N&&N){
        int i;
        int *a = new int[N+1];
        a[0] = 0;
        for(i=1; i<=N; ++i)
            cin >> a[i];
        int cost = 0;
        for(i=1; i<=N; ++i){
            if(a[i]>a[i-1])
                cost += (a[i]-a[i-1])*6;
            else
                cost += (a[i-1]-a[i])*4;
            cost += 5;
        }
        cout << cost << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值