PAT甲级1008(Java)

1008. Elevator (20)电梯

The highest building in our city has only one elevator. A request list is made up with N positive numbers(正数). The numbers denote at(指示) which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification(规格):

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41
Translations:
我们城市的高楼大厦只有一个电梯。一个请求表由N个正数组成。数字以一定的顺序电梯将停在哪层。电梯每上一层用6秒,每下一层用4秒。电梯在每一层停留5秒。
对于一个给定的请求表,你需要计算出表上需求的总时间。开始时电梯在0层,当电梯完成要求时不必回到地面。
输入格式:
每个输入包含一个测试用例。每个测试用例包含一个正整数N,随后输入N个正整数。输入的每个数都小于100.
输出格式:
每个测试用例在单独的一行打印总时间。

package com.jia.demo;

import java.util.Scanner;

public class test1008 {
  public static void main(String[]args){
	  int a[]=new int[110];
	  int sum=0;
     Scanner input=new Scanner(System.in);
     int n=input.nextInt();
     a[0]=input.nextInt();
      sum=sum+a[0]*6;
      sum+=5*n;
      for(int i=1;i<n;i++){
    	    a[i]=input.nextInt();
    	    if(a[i]>a[i-1]){//电梯上升 
    	      sum+=6*(a[i]-a[i-1]);
    	    }else{//电梯下降 
    	      sum+=4*(a[i-1]-a[i]);
    	    } 
}
      System.out.println(sum);
}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值