UVa 573 The Snail(蜗牛)

  The Snail 

A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% $\times$ 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's heightexceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.

DayInitial HeightDistance ClimbedHeight After ClimbingHeight After Sliding
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.

Input 

The input file contains one or more test cases, each on a line by itself. Each line contains four integers  H U D , and  F , separated by a single space. If  H  = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive.  H  is the height of the well in feet,  U  is the distance in feet that the snail can climb during the day,  D  is the distance in feet that the snail slides down during the night, and  F  is the fatigue factor expressed as a percentage. The snail never  climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides  D  feet at night.

Output 


For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactlyas shown in the example.

Sample Input 

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output 

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2


题目大意:

题目中的事例

一个蜗牛在一个6英尺的井中,它希望爬出井,在日出的时候可以向上爬3英尺,但是在晚上睡觉的时候会下降1英尺。蜗牛10%疲劳的因素这意味着在每个连续天蜗牛上爬比前一天少10% 3 = 0.3英尺(并且这个减少的距离一直是第一天上爬的10%)。在第几天蜗牛可以离开井?

天数初始高度白天攀爬距离攀爬之后的高度下落之后的高度
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-
在这里我们可以看见第三天蜗牛成功了。

现在任务是解决蜗牛爬井的问题。根据问题的参数,蜗牛最终是爬出井还是落回井底(换句话就是,蜗牛哪天高度超过井的高度,或者是负值),一定要指出这发生的那天。

输入:H:井的高度,U:蜗牛攀爬距离,D:蜗牛下落距离,F:疲劳因素=F%;

假设第i天之后还没有成功或者失败,那么该天攀爬距离是up[i-1] - F%*U;    下落距离依旧是D

注意点:

1. 在本题注意的地方,就是一组数据结束的标志是高度超过井高或者为负值!!!

2. 当然,每次攀爬后,就立即判断是否高出井!!!

3. 每天攀爬距离不能为负值,为负值的时候,令up=0;

4. 注意:解题的时候每天攀爬和攀爬距离都用double型


代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main(){
    int h, u, d, f, day;
    double up, down, change, height;

    while(~scanf("%d%d%d%d", &h,&u,&d,&f)&&(h||u||d||f)){
        up = u;
        down = d;
        change = (1.0*f)/100*up;
        day = 0;
        height = 0;
        while(height>=0&&height<=h){
            day++;
            height += up;
            if(height>h)   break;
            height -= down;

            up -= change;
            if(up <= 0)
                up = 0;
        }
        if(height>h)
            printf("success on day %d\n", day);
        else
            printf("failure on day %d\n", day);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值