1412201145-hd-The Snail

The Snail

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1537    Accepted Submission(s): 1122


Problem Description
A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.

Day Initial Height Distance Climbed Height After Climbing Height After Sliding
1 0 3 3 2
2 2 2.7 4.7 3.7
3 3.7 2.4 6.1 -

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.
 

Input
The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.
 

Output
For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.
 

Sample Input
  
  
6 3 1 10 10 2 1 50 50 5 3 14 50 6 4 1 50 6 3 1 1 1 1 1 0 0 0 0
 

Sample Output
  
  
success on day 3 failure on day 4 failure on day 7 failure on day 68 success on day 20 failure on day 2
 题目大意
        蜗牛爬洞,h为洞的高度,u为白天向上爬的高度,d为晚上向下滑的高度,f%为疲劳值。疲劳值是第一天白天向上爬的高度的f%,之后不会改变。但是之后每一天u都要减去疲劳值。判断蜗牛能不能爬出洞口,可以的话输出success....time(time为爬出洞口的时间),不可以的话输出failure...time(time为重新到洞低的时间)。
解题思路
       根据题目大意模拟就行,注意不要等号。
代码
#include<stdio.h>
int main()
{
	double h,u,d,f;
	double pilao,now;
	int time;
	while(scanf("%lf%lf%lf%lf",&h,&u,&d,&f),h)
	{
		pilao=u*f/100;
	//pilao是第一天u的%f不会变,但是从第二天开始,u每天都要减去pilao
	//pilao不变u变 
		time=1;
		if(h<u)//均不带等号 
		    printf("success on day %d\n",time);
		else
		{
			now=h-u+d;
			u-=pilao;
			while(1)
			{
				time++;
				now-=u;
				u-=pilao;
				if(now<0)
				{
					printf("success on day %d\n",time);
					break;
				}
				now+=d;
				if(now>h)
				{
					printf("failure on day %d\n",time);
					break;
				}
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值