POJ 3278 Catch That Cow(宽搜)

POJ 3278 Catch That Cow
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:农夫约翰要追他的牛,开始给你约翰的位置和牛的位置,约翰一次可以向前移一步,或者向后移一步,或者移动到当前坐标点*2的位置,问最少移动多少步到达牛的位置。

题解:
简单bfs,但是需要开个vis数组记录哪些点已经到过,防止塞进队列的数过多。

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
struct cc{
	int x,step;
};
queue<cc>q;
bool vis[2000000];
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	q.push((cc){n,0});
	int ans=0;
	vis[n]=1;
	while(!q.empty())
	{
		cc u=q.front(); q.pop();
		if(u.x==m)
		{
			ans=u.step;
			break;
		}
		if(u.x-1>=0&&!vis[u.x-1])
		{
			q.push((cc){u.x-1,u.step+1});
			vis[u.x-1]=1;
		}
		if(u.x+1<=100000&&!vis[u.x+1])
		{
			q.push((cc){u.x+1,u.step+1});
			vis[u.x+1]=1;
		}
		if(u.x*2<=100000&&!vis[u.x*2])
		{
			q.push((cc){u.x*2,u.step+1});
			vis[u.x*2]=1;
		}
	}
	printf("%d",ans);
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值