HDU - 2612 Find a way(宽搜)

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input
4 4
Y.#@

.#…
@…M
4 4
Y.#@

.#…
@#.M
5 5
Y…@.
.#…
.#…
@…M.
#…#
Sample Output
66
88
66

题意:Y和M要一起去肯德基,多组输入,给你一个m*n的地图,’.‘表示道路,’@'表示肯德基(有多个),‘Y’和‘M’表示两人的起始位置,’#'不能走。现在问你两人到同一家肯德基所需时间之和最少为多少。(两人分别可以上下左右移动,每移动一次需要11分钟,且一定会有解)

题解:两边BFS分别求出两人到各个肯德基所需的时间,再计算最小值。

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
struct cc{
	int x,y,step;
};
queue<cc>q1;
queue<cc>q2;
char map[205][205];
int vis1[205][205];
int vis2[205][205];
int dx[4]={1,0,0,-1};
int dy[4]={0,1,-1,0};
int m,n;
void bfs()
{
	while(!q1.empty())
	{
		cc u=q1.front(); q1.pop();
		for(int j=0;j<4;j++)
		{
			int mx=u.x+dx[j],my=u.y+dy[j];
			if(mx>=1&&mx<=n&&my>=1&&my<=m&&!vis1[mx][my])
			{
				if(map[mx][my]=='.'||map[mx][my]=='@')
				{
					q1.push((cc){mx,my,u.step+1});
					vis1[mx][my]=u.step+1;
				}
			}
		}
	}
	while(!q2.empty())
	{
		cc u=q2.front(); q2.pop();
		for(int j=0;j<4;j++)
		{
			int mx=u.x+dx[j],my=u.y+dy[j];
			if(mx>=1&&mx<=n&&my>=1&&my<=m&&!vis2[mx][my])
			{
				if(map[mx][my]=='.'||map[mx][my]=='@')
				{
					q2.push((cc){mx,my,u.step+1});
					vis2[mx][my]=u.step+1;
				}
			}
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(vis1,0,sizeof(vis1));
		memset(vis2,0,sizeof(vis2));
		while(!q1.empty()) q1.pop();
		while(!q2.empty()) q2.pop();
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='Y')
				{
					q1.push((cc){i,j,0});
					vis1[i][j]=1;
				}
				if(map[i][j]=='M')
				{
					q2.push((cc){i,j,0});
					vis2[i][j]=1;
				}
			}
		}
		bfs();
		int ans=1e9;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if(map[i][j]=='@'&&vis1[i][j]!=0&&vis2[i][j]!=0)
				{
					if(ans>vis1[i][j]+vis2[i][j])
					{
						ans=vis1[i][j]+vis2[i][j];
					}
				}
			}
		}
		printf("%d\n",ans*11);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值