TOJ 2829.Cow Counting

题目链接:http://acm.tju.edu.cn/toj/showp2829.html


2829.    Cow Counting
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1146    Accepted Runs: 571     Multiple test files



Farmer John wants to label his  N (1 ≤  N ≤ 1,000,000) cows, but cows don't like having the digit  L (0 ≤  L ≤ 9) written on them, so he avoids that.

If the cows are labeled with the smallest set of N positive integers that don't have the digit L, what is the largest number that Farmer John has to write on any cow?

Input

* Line 1: Two space-separated integers:  N and  L.

Output

* Line 1: A single integer that is the largest number that Farmer John has to write on any cow.

Sample Input

10 1

Sample Output

22

Input Details

Farmer John has 10 cows he needs to label without using the digit 1.

Output Details

The smallest 10 numbers he can use are: 2, 3, 4, 5, 6, 7, 8, 9, 20, and 22.



Source: USACO Open Competition 2007
Submit   List    Runs   Forum   Statistics

水题,暴力过

#include <stdio.h>
bool ok(int n,int l){
	while(n){
		if(n%10==l)
			return false;
		n/=10;
	} 
	return true;
}
int main(){
	int n,l;
	while(~scanf("%d%d",&n,&l)){
		int num=1,sum=0;
		while(sum<n){
			if(ok(num,l)){
				num++;
				sum++;
			}
			else
				num++;
		}
		printf("%d\n",num-1);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值