Farmer John‘s cows 简单题解

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.
FJ’s N cows (1 <= N <= 10,000)
all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.Input* Line 1: N* Lines 2…N+1: The location of each cow (in the range 0…1,000,000,000).
OutputThere are five cows at locations 1, 5, 3, 2, and 4.
Sample Input:
5
1
5
3
2
4
Sample Output
40
HintINPUT DETAILS:
There are five cows at locations 1, 5, 3, 2, and 4.
OUTPUT DETAILS:
Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.

这个原理是 :
求第n头牛 与(n-1)头牛的距离和
感觉用递归的方式 就可以了。
最主要是 求出b[1] 和 递归方程
b[n]=b[n-1]+(i-2)(a(n)-a(n-1))-(n-i)(a(n)-a(n-1))
上式原理可以按题中的例子简单解释一下:
1 2 3 4
1 1 2 3 (减n-2 加i-2)
2 1 1 2
3 2 1 1
4 3 2 1
代码如下:

#include<iostream>
using namespace std;
long long  a[10000],b[10000];  //一定要用long long
long long sum;
int main()
{          int n;   
  cin>>n;    
   int i,j;   
     for( i=1;i<=n;i++)    
        {        cin>>a[i];}       
         sort(a+1,a+n+1);  
              b[1]=0;     
         for( i=2;i<=n;i++)  //用一个循环求出b1.
            {    b[1]+=a[i]-a[1];   
             }     
                   sum=b[1];       
  for( i=2;i<=n;i++)     
  {       b[i]=b[i-1]+(i-2)*(a[i]-a[i-1])-((n-i)*(a[i]-a[i-1]));         
      sum+=b[i];         }          
        cout<<sum<<endl;
        return  0
        }
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值