Elevator

今天ac了一道题目,虽然很简单,但是让我这笨笨的脑袋想了好久。就想着来和大家分享一下。

题目描述

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop. 

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled. 
 

输入

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed. 
 

输出

Print the total time on a single line for each test case. 
 

样例输入

1 2
3 2 3 1
0

样例输出

17
41

我在第一次在OJ上提交时,显示答案错误。但是又没有错误提示,我就又去编译运行了一下,发现我在测试前面两组数据后很兴奋地去提交了,但是我忽略了当n=0时是没有输出的。

完整的代码如下:

#include<stdio.h>


int main()
{
  int n;
  while(scanf("%d",&n)!=EOF && n != 0)
  {
      int a[n];
      int k;
      for(k=0;k<n;k++)
        {
        scanf("%d",&a[k]);
        if(a[k]>=100) 
return 0;
        }
      int time;
      time=a[0]*6+5;
      for(k=0;k<n-1;k++)
      {
          if(a[k+1]>a[k]) 
 time+=(a[k+1]-a[k])*6+5;
          if(a[k+1]<a[k]) 
 time+=(a[k]-a[k+1])*4+5;
          if(a[k+1]==a[k]) 
 time+=5;
      }
      printf("%d\n",time);
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值