poj 1836 (动态规划之最长上升子序列)

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12503 Accepted: 4008

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4
 
题目意思是使剩下队列为a1 < a2 < a3 < ... < a(i ) <=> a(i+1) > a(i+2) > .. a(n-1) >a(n)时最少删除的人数。
AC代码:
 
#include<cstdio>
#include<algorithm>
using namespace std;
int num1[1010];
int num2[1010];
double a[1010];
int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++)
            scanf("%f",&a[i]);
        
        for(int i=0;i<n;i++)
            num1[i]=1;                
        for(int i=n-2;i>=0;i--)              //从右到左最长上升子序列 
            for(int j=n-1;j>i;j--){
            if(a[i]>a[j]&&num1[i]<num1[j]+1)
                num1[i]=num1[j]+1;
            }
        for(int i=0;i<n;i++)
            num2[i]=1;                
        for(int i=1;i<n;i++)              //从左到右最长上升子序列 
            for(int j=0;j<i;j++){
            if(a[i]>a[j]&&num2[i]<num2[j]+1)
                num2[i]=num2[j]+1;
            }
        int mx=0;
        for(int i=0;i<n;i++)                 //中点只有一个的时候 
            mx=max(mx,num1[i]+num2[i]-1);
        for(int i=0;i<n;i++)                 //中点有两个的时候 
            for(int j=i+1;j<n;j++)
                mx=max(mx,num2[i]+num1[j]);
        printf("%d\n",n-mx);
    }
    return 0;
} 

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值