Name PK

Name PK

时间限制: 1 Sec   内存限制: 128 MB
提交: 82   解决: 20
[ 提交][ 状态][ 论坛]

题目描述

Name PK is a funny game on the Internet. The game will calculate character’s property based on its name. Now we’re simulating a simple Name PK game. Each character has 3 parameters: HP, STR and SPD (HP for health point, STR for strength and SPD for attacking speed). For a name string of length N, Ci is ASCII code (decimal) of the i-th char.
PK rule: 1. Timer begins to increase from 1. When it is a multiple of (20-SPD), the corresponding character A has that SPD attack once, the opposite lose STR(A’s) HP. 2. When any side has a HP <= 0, the PK is over.

输入

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separate line, and it consists two strings separated by a whitespace, indicating the name of the characters. Technical Specification 1. Names contain only English letters. 2. The length of each character’s name is more than 1 and no more than 20. 3. T <= 1000.

输出

For each test case, output a line consisting of the result of the first character: “win”, “lose” or “tie”.

样例输入

3Sylvia xayIvan StacyBoyd Greg

样例输出

losewinlose
题目意思很好懂,不多说了,直接看代码吧!
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    scanf("%d",&T);
    while(T--){
        char ch1[25],ch2[25];
        int hp1,str1,spd1;
        int hp2,str2,spd2;
        scanf("%s%s",ch1,ch2);
        int tmp=0;
        for(int i=0;i<strlen(ch1);i++)
            tmp=(tmp+(83-ch1[i])*(83-ch1[i]))%97;
        hp1=300-tmp;
        tmp=1;
        for(int i=0;i<strlen(ch1);i++)
            tmp=(tmp*ch1[i])%79;
        str1=22+tmp;
        spd1=0;
        for(int i=0;i<strlen(ch1);i++)
            for(int j=i+1;j<strlen(ch1);j++)
                spd1=(spd1+ch1[i]*ch1[j])%11;
        
        tmp=0;
        for(int i=0;i<strlen(ch2);i++)
            tmp=(tmp+(83-ch2[i])*(83-ch2[i]))%97;
        hp2=300-tmp;
        tmp=1;
        for(int i=0;i<strlen(ch2);i++)
            tmp=(tmp*ch2[i])%79;
        str2=22+tmp;
        spd2=0;
        for(int i=0;i<strlen(ch2);i++)
            for(int j=i+1;j<strlen(ch2);j++)
                spd2=(spd2+ch2[i]*ch2[j])%11;
        int t1=20-spd1,t2=20-spd2;
        int dt1=t1,dt2=t2;
        while(hp1>0 && hp2>0){
            if(t1<t2){
                hp2-=str1;
                t1+=dt1;
            }
            else if(t1==t2){
                hp2-=str1;
                hp1-=str2;
                t1+=dt1;
                t2+=dt2;
            }
            else{
                hp1-=str2;
                t2+=dt2;
            }
        }
        if(hp1<=0 && hp2<=0)
            printf("tie\n");
        else if(hp1>0)
            printf("win\n");
        else
            printf("lose\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值