Prime Path
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11143 | Accepted: 6325 |
Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.
Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.
Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
1733
3733
3739
3779
8779
8179
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3 1033 8179 1373 8017 1033 1033
Sample Output
6 7 0
Source
AC代码:
#include<iostream>
#include<cmath>
#include<queue>
using namespace std;
struct Node{
int m,t;
Node(int M,int T):m(M),t(T){}
};
int prime[10010];
int sign[10010];
queue <Node> qu;
void isprime(){
for(int i=1001;i<=9999;i++){
int j;
for(j=2;j<=(int)sqrt(i+0.5);j++)
if(i%j==0){
prime[i]=0;
break;
}
if(j>(int)sqrt(i+0.5))
prime[i]=1;
}
}
int main(){
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
isprime();
int T; cin>>T;
while(T--){
int n,k,ans=99999;
cin>>n>>k;
for(int i=1001;i<=9999;i++)
sign[i]=0;
while(!qu.empty())
qu.pop();
qu.push(Node(n,0));
sign[n]=1;
while(!qu.empty()){
Node tmp=qu.front(); qu.pop();
if(tmp.m==k){
ans=min(ans,tmp.t);
//break;
}
int tp,tt;
tp=tmp.m;
tp/=10; tp*=10;
for(int i=0;i<=9;i++){ //变换个位数字
if(prime[tp] && !sign[tp]){
sign[tp]=1;
//cout<<tp<<' ';
qu.push(Node(tp,tmp.t+1));
}
tp+=1;
}
tp=tmp.m;
tt=tp%10;
tp/=100; tp*=100; tp+=tt;
for(int i=0;i<=9;i++){ //变换十位数字
if(prime[tp] && !sign[tp]){
sign[tp]=1;
//cout<<tp<<' ';
qu.push(Node(tp,tmp.t+1));
}
tp+=10;
}
tp=tmp.m;
tt=tp%100;
tp/=1000; tp*=1000; tp+=tt;
for(int i=0;i<=9;i++){ //变换百位数字
if(prime[tp] && !sign[tp]){
sign[tp]=1;
//cout<<tp<<' ';
qu.push(Node(tp,tmp.t+1));
}
tp+=100;
}
tp=tmp.m;
tp=tp%1000;
for(int i=1;i<=9;i++){ //变换千位数字
tp+=1000;
if(prime[tp] && !sign[tp]){
sign[tp]=1;
//cout<<tp<<' ';
qu.push(Node(tp,tmp.t+1));
}
}
}
//cout<<endl;
if(ans==99999)
cout<<"Impossible"<<endl;
else
cout<<ans<<endl;
}
return 0;
}