poj 3114(korasaju算法和dij算法)

Countries in War
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2407 Accepted: 751

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ E ≤ N2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, XY and H (1 ≤ XY ≤ N, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ OD ≤ N). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0

Source

South America 2006, Brazil Subregion

题目是求两点间最短路径,如果两点属于一个强连通分量,则距离为0.

korasaju求出强连通分量保存在scc中,重新建图(我这里是未缩点状态,即只把同一个强联通分量的点距离置为0),然后dij求出最短路,未缩点状态下floyed会超时的啊。

AC代码:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int scc[505],vis[505];
int G1[505][505],G2[505][505];
int n,m;
vector <int> s;
void dfs1(int u){
    vis[u]=1;
    for(int i=1;i<=n;i++){
        if(!vis[i] && G1[u][i] && G1[u][i]<999999)
            dfs1(i);
    }
    s.push_back(u);
}
void dfs2(int u,int k){
    scc[u]=k;
    for(int i=1;i<=n;i++){
        if(!scc[i] && G2[u][i] && G2[u][i]<999999)
            dfs2(i,k);
    }
}
void find_scc(){
    int k=0;
    s.clear();
    for(int i=1;i<=n;i++)
        scc[i]=vis[i]=0;
    for(int i=1;i<=n;i++)
        if(!vis[i])
            dfs1(i);
    for(int i=s.size()-1;i>=0;i--)
        if(!scc[s[i]])
            dfs2(s[i],++k);

    //重新建图
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++){
        if(scc[i]==scc[j])
            G1[i][j]=0;
    }
}
int dij(int st,int ed){
    int dis[505];
    for(int i=1;i<=n;i++){
        dis[i]=G1[st][i];
        vis[i]=0;
    }
    vis[st]=1;
    for(int i=2;i<=n;i++){
        int v,mn=999999;
        for(int j=1;j<=n;j++){
            if(!vis[j] && mn>dis[j]){
                mn=dis[j];
                v=j;
            }
        }
        vis[v]=1;
        if(mn==999999)
            break;
        for(int j=1;j<=n;j++){
            if(!vis[j] && dis[j]>mn+G1[v][j])
                dis[j]=dis[v]+G1[v][j];
        }
    }
    return dis[ed];
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0)
            break;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++){
                if(i==j)
                    G1[i][j]=G2[i][j]=0;
                else
                    G1[i][j]=G2[i][j]=999999;
            }
        while(m--){
            int x,y,h;
            scanf("%d%d%d",&x,&y,&h);
            G1[x][y]=h;
            G2[y][x]=h;
        }
        find_scc();          //kosaraju算法
//未缩点的floyed超时了,缩点懒得整了,直接上dij
//        for(int k=1;k<=n;k++)
//            for(int i=1;i<=n;i++)
//            for(int j=1;j<=n;j++)
//                if(G1[i][k]+G1[k][j]<G1[i][j])
//                    G1[i][j]=G1[i][k]+G1[k][j];

        scanf("%d",&m);
        while(m--){
            int x,y;
            scanf("%d%d",&x,&y);
            int ds=dij(x,y);
            if(ds!=999999)
                printf("%d\n",ds);
            else{
                printf("Nao e possivel entregar a carta\n");
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值