hdu 5191

Building Blocks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1323    Accepted Submission(s): 282


Problem Description
After enjoying the movie,LeLe went home alone. LeLe decided to build blocks.
LeLe has already built n piles. He wants to move some blocks to make W consecutive piles with exactly the same height H .

LeLe already put all of his blocks in these piles, which means he can not add any blocks into them. Besides, he can move a block from one pile to another or a new one,but not the position betweens two piles already exists.For instance,after one move,"3 2 3" can become "2 2 4" or "3 2 2 1",but not "3 1 1 3".

You are request to calculate the minimum blocks should LeLe move.
 

Input
There are multiple test cases, about 100 cases.

The first line of input contains three integers n,W,H(1n,W,H50000) . n indicate n piles blocks.

For the next line ,there are n integers A1,A2,A3,,An indicate the height of each piles. (1Ai50000)

The height of a block is 1.
 

Output
Output the minimum number of blocks should LeLe move.

If there is no solution, output "-1" (without quotes).
 

Sample Input
  
  
4 3 2 1 2 3 5 4 4 4 1 2 3 4
 

Sample Output
  
  
1 -1
Hint
In first case, LeLe move one block from third pile to first pile.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5193  5192  5191  5190  5189 
 


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>
using namespace std;
#define ll long long
int n;
ll W,H;
int a[200010];
ll max(ll t1,ll t2){
    if(t1>=t2){
        return t1;
    }
    return t2;
}
ll min(ll t1,ll t2){
    if(t1<=t2){
        return t1;
    }
    return t2;
}
int main(){
    while(scanf("%d%lld%lld",&n,&W,&H)!=EOF){
        ll s=W*H;
        ll ans=s;
        for(int i=0;i<W;i++){
            a[i]=0;
        }
        int len=W+n;
        for(int i=W;i<len;i++){
            scanf("%d",&a[i]);
            s-=a[i];
        }
        len+=W;
        for(int i=W+n;i<len;i++){
            a[i]=0;
        }
        if(s>0){
            printf("-1\n");
        }
        else{
            ll mn,mx;
            mn=ans;
            mx=0;
            for(int i=W;i<len;i++){
                int j=i-W;
                if(a[j]<=H){
                    mn-=H-a[j];
                }
                else{
                    mx-=a[j]-H;
                }

                if(a[i]<=H){
                    mn+=H-a[i];
                }
                else{
                    mx+=a[i]-H;
                }
                ans=min(ans,max(mx,mn));
            }
            printf("%lld\n",ans);
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值