Building Blocks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1323 Accepted Submission(s): 282
Problem Description
After enjoying the movie,LeLe went home alone. LeLe decided to build blocks.
LeLe has already built n piles. He wants to move some blocks to make W consecutive piles with exactly the same height H .
LeLe already put all of his blocks in these piles, which means he can not add any blocks into them. Besides, he can move a block from one pile to another or a new one,but not the position betweens two piles already exists.For instance,after one move,"3 2 3" can become "2 2 4" or "3 2 2 1",but not "3 1 1 3".
You are request to calculate the minimum blocks should LeLe move.
LeLe has already built n piles. He wants to move some blocks to make W consecutive piles with exactly the same height H .
LeLe already put all of his blocks in these piles, which means he can not add any blocks into them. Besides, he can move a block from one pile to another or a new one,but not the position betweens two piles already exists.For instance,after one move,"3 2 3" can become "2 2 4" or "3 2 2 1",but not "3 1 1 3".
You are request to calculate the minimum blocks should LeLe move.
Input
There are multiple test cases, about
100
cases.
The first line of input contains three integers n,W,H(1≤n,W,H≤50000) . n indicate n piles blocks.
For the next line ,there are n integers A1,A2,A3,……,An indicate the height of each piles. (1≤Ai≤50000)
The height of a block is 1.
The first line of input contains three integers n,W,H(1≤n,W,H≤50000) . n indicate n piles blocks.
For the next line ,there are n integers A1,A2,A3,……,An indicate the height of each piles. (1≤Ai≤50000)
The height of a block is 1.
Output
Output the minimum number of blocks should LeLe move.
If there is no solution, output "-1" (without quotes).
If there is no solution, output "-1" (without quotes).
Sample Input
4 3 2 1 2 3 5 4 4 4 1 2 3 4
Sample Output
1 -1HintIn first case, LeLe move one block from third pile to first pile.
Source
Recommend
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>
using namespace std;
#define ll long long
int n;
ll W,H;
int a[200010];
ll max(ll t1,ll t2){
if(t1>=t2){
return t1;
}
return t2;
}
ll min(ll t1,ll t2){
if(t1<=t2){
return t1;
}
return t2;
}
int main(){
while(scanf("%d%lld%lld",&n,&W,&H)!=EOF){
ll s=W*H;
ll ans=s;
for(int i=0;i<W;i++){
a[i]=0;
}
int len=W+n;
for(int i=W;i<len;i++){
scanf("%d",&a[i]);
s-=a[i];
}
len+=W;
for(int i=W+n;i<len;i++){
a[i]=0;
}
if(s>0){
printf("-1\n");
}
else{
ll mn,mx;
mn=ans;
mx=0;
for(int i=W;i<len;i++){
int j=i-W;
if(a[j]<=H){
mn-=H-a[j];
}
else{
mx-=a[j]-H;
}
if(a[i]<=H){
mn+=H-a[i];
}
else{
mx+=a[i]-H;
}
ans=min(ans,max(mx,mn));
}
printf("%lld\n",ans);
}
}
return 0;
}