HDOJ 4893 Wow! Such Sequence! (线段树)


Wow! Such Sequence!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4627    Accepted Submission(s): 1324


Problem Description

Recently, Doge got a funny birthday present from his new friend, Protein Tiger from St. Beeze College. No, not cactuses. It's a mysterious blackbox.

After some research, Doge found that the box is maintaining a sequence an of n numbers internally, initially all numbers are zero, and there are THREE "operations":

1.Add d to the k-th number of the sequence.
2.Query the sum of ai where l ≤ i ≤ r.
3.Change ai to the nearest Fibonacci number, where l ≤ i ≤ r.
4.Play sound "Chee-rio!", a bit useless.

Let F
0 = 1,F 1 = 1,Fibonacci number Fn is defined as F n = F n - 1 + F n - 2 for n ≥ 2.

Nearest Fibonacci number of number x means the smallest Fn where |F
n - x| is also smallest.

Doge doesn't believe the machine could respond each request in less than 10ms. Help Doge figure out the reason.
 

Input

Input contains several test cases, please process till EOF.
For each test case, there will be one line containing two integers n, m.
Next m lines, each line indicates a query:

1 k d - "add"
2 l r - "query sum"
3 l r - "change to nearest Fibonacci"

1 ≤ n ≤ 100000, 1 ≤ m ≤ 100000, |d| < 2
31 , all queries will be valid.
 

Output

For each Type 2 ("query sum") operation, output one line containing an integer represent the answer of this query.
 

Sample Input

      
      
1 1 2 1 1 5 4 1 1 7 1 3 17 3 2 4 2 1 5
 

Sample Output

      
      
0 22


#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<(b);++i)
const int maxn =100005;
const int mod = 10005;
const int INF = 1e9;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define rush() int T;scanf("%d",&T);while(T--)
ll tree1[maxn<<2];
ll tree2[maxn<<2];//伴随树,存储与tree数组数据最近的Fibonacci数
int flag[maxn<<2];
ll f[105];
ll ans;
void init()
{
    f[0]=f[1]=1;
    f(i,2,105)
    {
        f[i]=f[i-1]+f[i-2];
    }
}
void pushup(int rt)
{
    tree1[rt]=tree1[rt<<1]+tree1[rt<<1|1];
    tree2[rt]=tree2[rt<<1]+tree2[rt<<1|1];
}
void pushdown(int rt)
{
    if(flag[rt]==1)
    {
        flag[rt<<1]=flag[rt<<1|1]=1;
        tree1[rt<<1]=tree2[rt<<1];
        tree1[rt<<1|1]=tree2[rt<<1|1];
        flag[rt]=0;
    }
}
ll getfibo(ll n)
{
    int x=lower_bound(f,f+100,n)-f;
    if(x==0)
        return 1;
    return f[x]-n>=n-f[x-1]?f[x-1]:f[x];
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        tree1[rt]=0;
        tree2[rt]=1;
        flag[rt]=0;
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int p,int c,int l,int r,int rt)
{
    if(l==r)
    {
        tree1[rt]+=c;
        tree2[rt]=getfibo(tree1[rt]);
        flag[rt]=0;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(p<=m)
    {
        update(p,c,lson);
    }
    else update(p,c,rson);
    pushup(rt);
}
void f_update(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        tree1[rt]=tree2[rt];
        flag[rt]=1;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(L<=m)
    {
        f_update(L,R,lson);
    }
    if(m<R)
    {
        f_update(L,R,rson);
    }
    pushup(rt);
}
void query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        if(flag[rt])
            ans+=tree2[rt];
        else
            ans+=tree1[rt];
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(L<=m)
    {
        query(L,R,lson);
    }
    if(m<R)
    {
        query(L,R,rson);
    }
}
int main()
{
    int n,m;
    int a,b,c;
    init();
    while(~scanf("%d%d",&n,&m))
    {
        mst(tree1,0);
        mst(tree2,0);
        mst(flag,0);
        build(1,n,1);
        while(m--)
        {
            ans=0;
            scanf("%d%d%d",&a,&b,&c);
            if(a==1)
            {
                update(b,c,1,n,1);
            }
            if(a==2)
            {
                query(b,c,1,n,1);
                printf("%I64d\n",ans);
            }
            if(a==3)
            {
                f_update(b,c,1,n,1);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值