HDOJ 1247 Hat’s Words(strncpy函数的运用)


Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14572    Accepted Submission(s): 5207


Problem Description

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

 


Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

 


Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

 


Sample Input

 
 
a ahat hat hatword hziee word

 


Sample Output

 
 
ahat hatword



先介绍下strncpy函数:

函数原型:char *strncpy(char *dest, const char *src, int n)

把src所指向的字符串中以src地址开始的前n个字节复制到dest所指的数组中,并返回dest

如果n<src的长度,只是将src的前n个字符复制到dest的前n个字符,不自动添加'\0',也就是结果dest不包括'\0',需要再手动添加一个'\0'。如果src的长度小于n个字节,则以NULL填充dest直到复制完n个字节。


#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<=(b);++i)
const int maxn = 26;
const int mod = 1e9+7;
const int INF = 1e9;
#define ll long long
#define rush() int T;scanf("%d",&T);while(T--)
struct Trie
{
	bool isword;
	Trie *next[maxn];
	Trie()
	{
		isword=false;
		mst(next,0);
	}
}*root,*p;
void insert (char *s)
{
	int i=0,k=0;
	p=root;
	for(i=0;s[i];i++)
	{
		k=s[i]-'a';
		if(!p->next[k])
			p->next[k]=new Trie();
		p=p->next[k];
	}
	p->isword=true;
}
bool find(char*s)
{
	int i=0,k=0;
	p=root;
	for(i=0;s[i];i++)
	{
		k=s[i]-'a';
		p=p->next[k];
		if(!p)
			return false;
	}
	return p->isword ;
}
int main()
{
	char str[50005][100];
	char str1[100];
	char str2[100];
	root=new Trie();
	int count =0;
	while(scanf("%s",str[count])!=EOF)
		insert(str[count++]);
	for(int i=0;i<count;i++)
	{
		int len=strlen(str[i]);
		for(int j=1;j<len;j++)
		{
			strncpy(str1,str[i],j);
			str1[j]='\0';
			strncpy(str2,str[i]+j,len-j);
			str2[len-j]='\0';
			if(find(str1)&&find(str2))
			{
				printf("%s\n",str[i]);
				break;
			}
		}
	}
	return 0;
}

不知道为什么这个程序能够AC,但一运行就崩溃。。。
不解,不解。。。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值