HDOJ 1505 City Game (单调栈)

City Game

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6965    Accepted Submission(s): 3010

Problem Description

Bob is a strategy gameprogramming specialist. In his new city building game the gaming environment isas follows: a city is built up by areas, in which there are streets,trees,factories and buildings. There is still some space in the area that isunoccupied. The strategic task of his game is to win as much rent money fromthese free spaces. To win rent money you must erect buildings, that can only berectangular, as long and wide as you can. Bob is trying to find a way to buildthe biggest possible building in each area. But he comes across some problems –he is not allowed to destroy already existing buildings, trees, factories andstreets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equalsquare units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into Kareas. Each one of the areas is rectangular and has a different grid size withits own length M and width N.The existing occupied units are marked with thesymbol R. The unoccupied units are marked with the symbol F.

 

 

Input

The first line of the inputcontains an integer K – determining the number of datasets. Next lines containthe area descriptions. One description is defined in the following way: Thefirst line contains two integers-area length M<=1000 and width N<=1000,separated by a blank space. The next M lines contain N symbols that mark thereserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

 

 

Output

For each data set in the inputprint on a separate line, on the standard output, the integer that representsthe profit obtained by erecting the largest building in the area encoded by thedata set.

 

 

Sample Input

2

5 6

R F F F F F

F F F F F F

R R R F F F

F F F F F F

F F F F F F

 

5 5

R R R R R

R R R R R

R R R R R

R R R R R

R R R R R

 

 

Sample Output

45

0



是HDOJ1506的升级版,对于每一行都重新给定h[i],运用单调栈求出覆盖面积的最大值


#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<(b);++i)
const int maxn = 1005;
const int mod = 9973;
#define ll long long
#define rush() int T;scanf("%d",&T);while(T--)
int n,m;
int h[maxn],L[maxn],R[maxn];
char str[maxn][maxn];
char c[5];
int main()
{
    rush()
    {
        int ans=0;
        scanf("%d%d",&n,&m);
        mst(h,0);
        f(i,0,n)
        f(j,0,m)
        {
            scanf("%s",c);
            str[i][j]=c[0];
        }
        f(i,0,n)
        {
            f(j,0,m)
            {
                if(str[i][j]=='F')
                    h[j]++;
                else h[j]=0;
            }
            stack<int> s;
            f(j,0,m)
            {
                if(s.size()&&h[s.top()]>=h[j])
                    s.pop();
                if(s.empty())
                    L[j]=0;
                else
                    L[j]=s.top()+1;
                s.push(j);
            }
            while(s.size())
                s.pop();
            for(int j=m-1; j>=0; j--)
            {
                if(s.size()&&h[s.top()]>=h[j])
                    s.pop();
                if(s.empty())
                    R[j]=m;
                else
                    R[j]=s.top();
                s.push(j);
            }
            f(j,0,m)
            {
                int cnt=h[j]*(R[j]-L[j]);
                ans=max(ans,cnt);
            }
        }
        printf("%d\n",ans*3);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值