POJ-1258Agri-Net

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

用了prim算法 <我认为一般的prim算法里面含有三个数组,1 储存输入数据的二维数组 2 是否加入集合的数组bj[]  3 储存最短边的数组> 详情看代码注释



/***
prim算法


*/
#include<stdio.h>
#include<string.h>
int mp[150][150],low[150],bj[150],n;
#define  INF 99999999
int prim()
{
   int i,j,k,sum,time;


   for(i=1;i<=n;i++)
   {
       low[i]=mp[1][i];///先为当前最短边初始化
   }
   bj[1]=1;
   sum=0;
   time=1;
   while(time<=n-1)///因为每循环一次找出一个点,所以只要循环n-1次一定能够把最小生成树找出来
   {
        int min1=INF;
        for(i=1; i<=n; i++)///找两个点之间的最短距离
        {
            if(low[i]<min1&&bj[i]==0)///注意&&后面的条件  
            {
                min1=low[i];
                j=i;
            }
        }
        sum+=min1;
        bj[j]=1;///把找到的那个点加入到点集中<表示点j加入了构成最短路点的集合中>
        for(i=1;i<=n;i++)
        {
            if(low[i]>mp[j][i] && bj[i]==0)///更新最短边
            {
                low[i]=mp[j][i];
            }
        }
        time++;
   }
   return sum;
}
int main()
{
    int i,j,k;
    while(~scanf("%d",&n))
    {
        memset(mp,0,sizeof(mp));
        memset(bj,0,sizeof(bj));///判断是否加入集合<这个集合指的是构造最短路的点做构成的集合>
        memset(low,0,sizeof(low));///LOW数组存当前以点i为一个端点的边的最小值
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&mp[i][j]);
            }
        }
        k=prim();
        printf("%d\n",k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值