大疆笔试题目(2023-08-13)

1. 输出无重复3位数

时间限制: 3000MS
内存限制: 65536KB
题目描述:
从{1,2,3,4,5,6,7,8,9}中随机挑选不重复的5个数字作为输入数组’selectedDigits’,能组成多少个互不相同且无重复数字的3位数?请编写程序,从小到大顺序,以数组形式,输这些3位数。

输入描述
selectedDigits = {1,2,3,4,5}

输出描述
123 124 125 132 134 135 142 143 145 152 153 154 213 214 215 231 234 235 241 243 245 251 253 254 312 314 315 321 324 325 341 342 345 351 352 354 412 413 415 421 423 425 431 432 435 451 452 453 512 513 514 521 523 524 531 532 534 541 542 543

样例输入
5
1 2 3 4 5
样例输出
123 124 125 132 134 135 142 143 145 152 153 154 213 214 215 231 234 235 241 243 245 251 253 254 312 314 315 321 324 325 341 342 345 351 352 354 412 413 415 421 423 425 431 432 435 451 452 453 512 513 514 521 523 524 531 532 534 541 542 543

提示
整型数组

数据格式:以空格分隔的整型数字。

样例:

1 2 3

#include <iostream>
#include <vector>
#include <numeric>
#include <limits>

using namespace std;

class Solution {
    vector<int> res;
    void dfs(vector<int>& selectedDigits, vector<int> cur, vector<bool>& isUsed) {
        if (cur.size() == 3) {
            res.push_back(cur[0] * 100 + cur[1] * 10 + cur[2]);
            return;
        }
        for (int i = 0; i < selectedDigits.size(); i++) {
            if (isUsed[i] == false) {
                isUsed[i] = true;
                cur.push_back(selectedDigits[i]);
                dfs(selectedDigits, cur, isUsed);
                cur.pop_back();
                isUsed[i] = false;
            }
        }
    }
public:

    /* Write Code Here */
    vector < int > ThreeDigitNumbers(vector < int > selectedDigits) {
        vector<bool> isUsed(5);
        vector<int> cur;
        dfs(selectedDigits, cur, isUsed);
        return res;
    }
};
int main() {
    vector < int > res;

    int selectedDigits_size = 0;
    cin >> selectedDigits_size;

    vector<int> selectedDigits;
    int selectedDigits_item;
    for (int selectedDigits_i = 0; selectedDigits_i < selectedDigits_size; selectedDigits_i++) {
        cin >> selectedDigits_item;

        selectedDigits.push_back(selectedDigits_item);
    }

    Solution* s = new Solution();
    res = s->ThreeDigitNumbers(selectedDigits);
    for (int res_i = 0; res_i < res.size(); res_i++) {
        cout << res[res_i] << endl;;
    }
    return 0;
}

在这里插入图片描述

2. 计算无人机飞行坐标

时间限制: 3000MS
内存限制: 65536KB
题目描述:
编写一个程序,模拟无人机的飞行路径。给定一个包含指令的字符串 (例如:“RUDDLLUR”),每个指令代表无人机在二维平面上移动的方向(U:前、D:后、L:左、R:右),请计算无人机的最终坐标并输出。

输入描述
RUDDLLURRR

输出描述
无人机的最终坐标是: (2, 0)

样例输入
​RUDDLLUR
样例输出
0 0

提示
无人机开始的坐标是(0,0),每执行1个指令,对应坐标方向+1。

#include <iostream>
#include <vector>
#include <numeric>
#include <limits>
#include <string>

using namespace std;

class Solution {
public:

    /* Write Code Here */
    vector < int > calculateFinalPositi(string instructions) {
        int x = 0, y = 0;
        for (int i = 0; i < instructions.size(); i++) {
            if (instructions[i] == 'U') {
                y++;
            }
            else if (instructions[i] == 'D') {
                y--;
            }
            else if (instructions[i] == 'L') {
                x--;
            }
            else if (instructions[i] == 'R') {
                x++;
            }
        }
        vector<int> res(2);
        res[0] = x;
        res[1] = y;
        return res;
    }
};
int main() {
    vector < int > res;

    string instructions;
    getline(cin, instructions);
    Solution* s = new Solution();
    res = s->calculateFinalPositi(instructions);
    for (int res_i = 0; res_i < res.size(); res_i++) {
        cout << res[res_i] << endl;;
    }

    return 0;
}

在这里插入图片描述

  • 16
    点赞
  • 15
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Cherries Man

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值