hdu 2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19122    Accepted Submission(s): 7993


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 题意:
有一张h*w大的板,需要往上贴n张海报,每张海报大小1*wi,尽量往上,左贴,求每张海报贴的高度,如果该张海报不能贴,则输出-1.
思想:
我没有想到线段树的做法(刚开始练线段树- -),然后上网搜了一波题解,发现,用线段树思想可以做该题,树上每个点保存剩余的位置(如果不是叶子节点则保存剩余的最大位置),然后与非叶子节点的左右节点值比较,如果wi<非叶子节点的左节点,则向左找,否则向右找,下面给出AC代码
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<stack>
#include<queue>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#define mem(a,b) memset(a,b,sizeof(a))
#define memmax(a) memset(a,0x3f,sizeof(a))
#define pfn printf("\n")
#define ll __int64
#define mod 1000000007
#define sf(a) scanf("%d",&a)
#define sf64(a) scanf("%I64d",&a)
#define sf2(a,b) scanf("%d%d",&a,&b)
#define sf3(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define sf4(a,b,c,d) scanf("%d%d%d%d",&a,&b,&c,&d)
#define sff(a) scanf("%f",&a)
#define sfs(a) scanf("%s",a)
#define sfs2(a,b) scanf("%s%s",a,b)
#define sfs3(a,b,c) scanf("%s%s%s",a,b,c)
#define sfc(a) scanf("%c",&a)
#define str(a) strlen(a)
#define debug printf("***\n")
const double PI = acos(-1.0);
const double e = exp(1.0);
const int INF = 0x7fffffff;;
template<class T> T gcd(T a, T b) { return b ? gcd(b, a % b) : a; }
template<class T> T lcm(T a, T b) { return a / gcd(a, b) * b; }
template<class T> inline T Min(T a, T b) { return a < b ? a : b; }
template<class T> inline T Max(T a, T b) { return a > b ? a : b; }
bool cmpbig(int a, int b){ return a>b; }
bool cmpsmall(int a, int b){ return a<b; }
using namespace std;
#define MAX 1000010
struct arnode
{
	int left;
	int right;
	int leave;
}node[4*MAX];
int h,w,n;
void build(int root,int l,int r)
{
	node[root].leave=w;
	node[root].left=l;node[root].right=r;
	if(l==r)
		return;
	int mid=(l+r)>>1;
	build(root<<1,l,mid);
	build((root<<1)+1,mid+1,r);
}
int query(int root,int wi)
{
	if(node[root].left==node[root].right)
	{
		node[root].leave-=wi;
		return node[root].left;
	}
	int pos;
	if(wi<=node[root<<1].leave)
		 pos=query(root<<1,wi);
	else
		pos=query((root<<1)+1,wi);
	node[root].leave=max(node[root<<1].leave,node[(root<<1)+1].leave);
	return pos;
}
int main()
{
	//freopen("data.in","r",stdin);
	//int h,w,n;
	while(~sf3(h,w,n))
	{
		if(h>n)
			h=n;
		build(1,1,h);
		while(n--)
		{
			int wi;
			sf(wi);
			wi>node[1].leave?printf("-1\n"):printf("%d\n",query(1,wi));
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值