zoj_3203Light Bulb

Light Bulb
http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3203


Time Limit:1 Second Memory Limit:32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integerT(T<= 100), indicating the number of cases.

Each test case contains three real numbersH,handDin one line.His the height of the light bulb whilehis the height of mildleopard.Dis distance between the light bulb and the wall. All numbers are in range from 10-2to 103, both inclusive, andH-h>= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
 
 
如图,人左右走动,求影子L的最长长度。
根据图,很容易发现当灯,人的头部和墙角成一条直线时(假设此时人站在A点),此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人从A点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用三分法来求解。
 
 
#include <iostream>
#include <cstdio>
using namespace std;

double D,H,h;
const double EPS = 1e-10;

double Cal(double L)
{
	return D * (h - L) / (H - L) + L;
}

double Solve(void)
{
	double Left, Right;
	double mid, midmid;
	double mid_value, midmid_value;
	Left = 0; Right = h;
	while (Left + EPS < Right)
	{
		mid = (Left + Right) / 2;
		midmid = (mid + Right) / 2;
		mid_value = Cal(mid);
		midmid_value = Cal(midmid);
		if (mid_value >= midmid_value) Right = midmid;
		else Left = mid;
	}
	return Left;
}

int main()
{
	freopen("in.txt","r",stdin);
	int t;
	cin>>t;
	while(t--)
	{
		cin>>H>>h>>D;
		printf("%.3lf\n",Cal(Solve()));
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值