ZOJ 3203 Light Bulb (三分)

 

Light Bulb


Time Limit: 1 Second      Memory Limit: 32768 KB


 

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

 

3
2 1 0.5
2 0.5 3
4 3 4

 

Sample Output

 

1.000
0.750
4.000

 


Author: GUAN, Yao
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

 

 

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3203

 

 

题意:求人的影子在灯光下投影到地面和墙上的最大值。

思路:设x表示人和灯之间的距离,用k表示人投影到墙上的长度,通过三角形相似可得公式:(H-h)/(H-k)= X / D   => k = H - (H-h)*D/x;则L = k + D - x;

上界r = D, 下界l = D*(H-h)/H

 

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double eps = 1e-6;
int t;
double H,h,D;

double val(double x){
    return  H - (H-h)*D/x + D-x;
}

int main(){
    scanf("%d",&t);
    while(t --){
        scanf("%lf%lf%lf",&H,&h,&D);
        double l = D - h*D/H, r = D;
        while(l + eps < r){
            double lm = l + (r - l) / 3;
            double rm = r - (r - l) / 3;
            if(val(lm) < val(rm)) l = lm;
            else r = rm;
        }
        printf("%.3lf\n",val(r));
    }
    return 0;
}

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值