poj_2481Cows

Cows
Time Limit:3000MS Memory Limit:65536K
Total Submissions:9871 Accepted:3233

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow iand cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow iis stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
#pragma warning(disable : 4996)
const int MAXN = 100005;
typedef struct Node
{
	int s;
	int e;
	int pos;
}Node;
Node node[MAXN];
int tree[MAXN];
int level[MAXN];

bool cmp(Node x,Node y)
{
	if(x.e == y.e) return x.s < y.s;
	else return x.e > y.e;
}

int LowBit(int t)
{
	return t&(-t);  
}

void Update(int pos, int num)
{
	while(pos <= MAXN)
	{
		tree[pos] += num;
		pos += LowBit(pos);
	}
}

int GetSum(int end)
{
	int sum = 0;
	while(end > 0)
	{
		sum += tree[end];
		end -= LowBit(end);
	}
	return sum;
}

int main()
{
	freopen("in.txt", "r", stdin);
	int n, x, y;
	while(scanf("%d", &n) != EOF)
	{
		memset(tree, 0, sizeof(tree));
		if(n==0)
		{
			break;
		}
		for(int i = 1; i <= n; i++)
		{
			scanf("%d %d", &x, &y);
			node[i].pos = i;
			node[i].s = x + 1;
			node[i].e = y + 1;
		}
		sort(node + 1, node + n + 1, cmp);
		for (int i = 1; i <= n; i++)
		{
			cout << node[i].pos << " " << node[i].s << " " << node[i].e << endl;
		}
		for(int i = 1; i <= n; i++)
		{
			Update(node[i].s, 1);
			level[node[i].pos] = GetSum(node[i].s) - 1;
		}
		for (int i = 1; i < n; i++)
		{
			printf("%d ", level[i]);
		}
		printf("%d\n", level[n]);
	}
}

9
5 5
5 6
1 4
4 5
1 4
4 6
2 3
3 5
1 4

4 1 0 2 0 0 3 0 0
没有考虑相同的点,导致WA,后来想一想,这样也不能满足 Ei - Si > Ej - Sj。也就是说排除两组数据相同的情况,任何满足Si <= Sj and Ej <= Ei 的必然会满足Ei - Si > Ej - Sj。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
#pragma warning(disable : 4996)
const int MAXN = 100005;
typedef struct Node
{
	int s;
	int e;
	int pos;
}Node;
Node node[MAXN];
int tree[MAXN];
int level[MAXN];

bool cmp(Node x,Node y)
{
	if(x.e == y.e) return x.s < y.s;
	else return x.e > y.e;
}

int LowBit(int t)
{
	return t&(-t);  
}

void Update(int pos, int num)
{
	while(pos <= MAXN)
	{
		tree[pos] += num;
		pos += LowBit(pos);
	}
}

int GetSum(int end)
{
	int sum = 0;
	while(end > 0)
	{
		sum += tree[end];
		end -= LowBit(end);
	}
	return sum;
}

int main()
{
	freopen("in.txt", "r", stdin);
	int n, x, y;
	while(scanf("%d", &n) != EOF)
	{
		memset(tree, 0, sizeof(tree));
		if(n == 0)
		{
			break;
		}
		for(int i = 1; i <= n; i++)
		{
			scanf("%d %d", &x, &y);
			node[i].pos = i;
			node[i].s = x + 1;
			node[i].e = y + 1;
		}
		sort(node + 1, node + n + 1, cmp);
		/*for (int i = 1; i <= n; i++)
		{
			cout << node[i].pos << " " << node[i].s << " " << node[i].e << endl;
		}*/
		Update(node[1].s, 1);
		level[node[1].pos] = GetSum(node[1].s) - 1;
		x = node[1].s;
		y = node[1].e;
		for(int i = 2; i <= n; i++)
		{
			if(node[i].s == x && node[i].e == y)
			{
				level[node[i].pos] = level[node[i-1].pos];
				Update(node[i].s, 1);
				continue;
			}
			x = node[i].s;
			y = node[i].e;
			Update(node[i].s, 1);
			level[node[i].pos] = GetSum(node[i].s) - 1;
		}
		for (int i = 1; i < n; i++)
		{
			printf("%d ", level[i]);
		}
		printf("%d\n", level[n]);
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值