经典LIS问题拓展——Ignatius and the Princess IV

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

InputThe input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

匆匆一看,似乎摸不着头绪,但多想想我们发现原问题可以做进一步简化:

对一组每个单元包含三个元素的数据,按某种顺序取用,然后选取一些满足这种顺序的数据使得和最大

进一步分析:我们知道一类前置知识——最小和的lis问题,我们发现,这一题和此类题十分相似,于是我们自然而然求得做法

先排序,再套用最小和lis的模板
%%%%%%%%%%%%%%%
那么怎么排序呢?
即:长方体先要以长度排序,长度相同则宽度小的在上。
%%%%%%%%%%%%%%%
为什么要这样排序呢?
因为我们要尽可能使长方体的长和宽成一条上升曲线,这样我们才不会遗漏
一个反例:长度最大的放第一个,最小的放最后,那么只能选取第一个,显然不符合条件。
%%%%%%%%%%%%%%%

最后就是愉快的写代码啦

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node{
	int l;
	int r;
	int h;
}p[200];
bool cmp(node x,node y)
{
	if(x.l==y.l) return x.r<y.r;
	return x.l<y.l;
}

int main()
{
	int n,temp = 0;
	while(cin>>n)
	{
		if(n==0) break;
		temp++;
		int dp[200]={0};
		int cnt = 0;
		for(int i=1;i<=n;i++)//存数据,三个元素是长宽高,共有六种可能
		{
			int a,b,c;
			cin>>a>>b>>c;
			p[++cnt].h = a;p[cnt].l = b;p[cnt].r = c;
			p[++cnt].h = a;p[cnt].l = c;p[cnt].r = b;
			p[++cnt].h = b;p[cnt].l = a;p[cnt].r = c;
			p[++cnt].h = b;p[cnt].l = c;p[cnt].r = a;
			p[++cnt].h = c;p[cnt].l = b;p[cnt].r = a;
			p[++cnt].h = c;p[cnt].l = a;p[cnt].r = b;
		}
	
		sort(p+1,p+cnt+1,cmp);//排序
//		dp[1] = p[1].h;
		for(int i=1;i<=cnt;i++)//lis无脑模板
		{
			int maxn = 0;
			for(int j=1;j<i;j++)
			{
				if(p[i].r>p[j].r&&p[i].l>p[j].l)
					maxn = max(dp[j],maxn);
			}
			dp[i] = p[i].h+maxn;
//			cout<<"this -> "<<dp[i]<<endl;
		}
		int maxn = 0;
		for(int i=1;i<=cnt;i++)
		{
			maxn = max(dp[i],maxn);
		}
		//输出结果
		printf("Case %d: maximum height = %d\n",temp,maxn);
//		cout<<maxn<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值