广度优先搜索 BFS

A - Rescue

 https://vjudge.net/contest/242570#problem/A

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

代码:

#include <stdio.h>
#include <queue>
#include <string.h> 
#include <iostream>
using namespace std;
int n,m;
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char str[300][300];
int vis[300][300];
struct node
{
	int x,y,time;
	friend bool operator<(node a,node b){
		return a.time>b.time;
	}
};
int BFS(int sx,int sy)
{
    node now,next;
	priority_queue<node> q;
	memset(vis,0,sizeof(vis));
	now.x=sx;
	now.y=sy;
	now.time=0;
	q.push(now);
	vis[sx][sy]=1;
	while(!q.empty()){
		now=q.top();
		q.pop();
	for(int i=0;i<4;i++){
		next.x=now.x+d[i][0];
		next.y=now.y+d[i][1];
		if(next.x>=0&&next.x<n&&next.y>=0&&next.y<m&&str[next.x][next.y]!='#'&&vis[next.x][next.y]!=1)
		{
			vis[now.x][now.y]=1;
			if(str[next.x][next.y]=='r')
			{
				printf("%d\n",now.time+1);
				return 0;
			}
			if(str[next.x][next.y]=='.')
			next.time=now.time+1;
			else if(str[next.x][next.y]=='x')
			next.time=now.time+2;
			q.push(next);
		}
	}
 }
 printf("Poor ANGEL has to stay in the prison all his life.\n");
 return 0;
}
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
	int sx=0,sy=0,i,j;	
	for(i=0;i<n;i++)
	scanf("%s",str[i]);
	for(i=0;i<n;i++){
		for(j=0;j<m;j++){
			if(str[i][j]=='a')
			{
			sx=i;
			sy=j;
		    }
		}
	}
	BFS(sx,sy);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于LSTM的财务因子预测选股模型LSTM (Long Short-Term Memory) 是一种特殊的循环神经网络(RNN)架构,用于处理具有长期依赖关系的序列数据。传统的RNN在处理长序列时往往会遇到梯度消失或梯度爆炸的问题,导致无法有效地捕捉长期依赖。LSTM通过引入门控机制(Gating Mechanism)和记忆单元(Memory Cell)来克服这些问题。 以下是LSTM的基本结构和主要组件: 记忆单元(Memory Cell):记忆单元是LSTM的核心,用于存储长期信息。它像一个传送带一样,在整个链上运行,只有一些小的线性交互。信息很容易地在其上保持不变。 输入门(Input Gate):输入门决定了哪些新的信息会被加入到记忆单元中。它由当前时刻的输入和上一时刻的隐藏状态共同决定。 遗忘门(Forget Gate):遗忘门决定了哪些信息会从记忆单元中被丢弃或遗忘。它也由当前时刻的输入和上一时刻的隐藏状态共同决定。 输出门(Output Gate):输出门决定了哪些信息会从记忆单元中输出到当前时刻的隐藏状态中。同样地,它也由当前时刻的输入和上一时刻的隐藏状态共同决定。 LSTM的计算过程可以大致描述为: 通过遗忘门决定从记忆单元中丢弃哪些信息。 通过输入门决定哪些新的信息会被加入到记忆单元中。 更新记忆单元的状态。 通过输出门决定哪些信息会从记忆单元中输出到当前时刻的隐藏状态中。 由于LSTM能够有效地处理长期依赖关系,它在许多序列建模任务中都取得了很好的效果,如语音识别、文本生成、机器翻译、时序预测等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值