题目描述
一棵树有n个节点,其中1号节点为根节点。
输入
第一行是整数n,表示节点数
后面若干行,每行两个整数a b,表示b是a的子节点。
输出
求这棵树的高度(根节点为第1层)
样例输入
5 1 2 1 3 3 4 3 5
样例输出
3
#include<bits/stdc++.h>
using namespace std;
const int maxn=10010;
struct node{
int layer;
vector<int> child;
}tree[maxn];
int n,a,b,h;
queue<int> q;
void BFS(int root){
h=0;
tree[root].layer=1;
q.push(root);
if(tree[root].layer>h) h=tree[root].layer;
while(!q.empty()){
int j=q.front();
q.pop();
for(int i=0;i<tree[j].child.size();i++){
int child=tree[j].child[i];
tree[child].layer=tree[j].layer+1;
q.push(child);
if(tree[child].layer>h) h=tree[child].layer;
}
}
}
int main(){
cin>>n;
for(int i=0;i<n-1;i++){
cin>>a>>b;
tree[a].child.push_back(b);
}
BFS(1);
cout<<h<<endl;
return 0;
}