题目描述
判断两序列是否为同一二叉搜索树序列
输入
开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉搜索树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉搜索树。
输出
如果序列相同则输出YES,否则输出NO
样例输入
6 45021 12045 54120 45021 45012 21054 50412 0
样例输出
NO NO YES NO NO NO
#include<bits/stdc++.h>
using namespace std;
const int maxn=10;
struct node{
int data;
node *left,*right;
};
vector<int> origipre,nowpre,origiin,nowin;
int n;
char tree[maxn];
void insert(node* &root,int data){
if(root==NULL){
root=new node;
root->data=data;
root->left=root->right=NULL;
return;
}
if(data==root->data) return;
else if(data<root->data) insert (root->left,data);
else insert(root->right,data);
}
node* Create(char data[],int n){
node* root=NULL;
for(int i=0;i<n;i++){
insert(root,data[i]-'0');
}
return root;
}
void preorder(node *root,vector<int> &v){
if(root==NULL) return;
v.push_back(root->data);
preorder(root->left,v);
preorder(root->right,v);
}
void inorder(node* root,vector<int> &v){
if(root==NULL) return;
inorder(root->left,v);
v.push_back(root->data);
inorder(root->right,v);
}
void postorder(node* root,vector<int> &v){
if(root==NULL) return;
postorder(root->left,v);
postorder(root->right,v);
v.push_back(root->data);
}
int main(){
while(~scanf("%d",&n),n){
scanf("%s",tree);
int len=strlen(tree);
node* root=Create(tree,len);
preorder(root,origipre);
inorder(root,origiin);
for(int i=0;i<n;i++){
char a[maxn];
scanf("%s",a);
int lenx=strlen(a);
node* rootx=Create(a,lenx);
preorder(rootx,nowpre);
inorder(rootx,nowin);
if(origipre==nowpre&&origiin==nowin)
printf("YES\n");
else printf("NO\n");
nowpre.clear();//注意清空此次存储的数据
nowin.clear();
}
origipre.clear();
origiin.clear();
}
return 0;
}