sdau三 1001

问题:给出一串数,求最大子序列的和。

sample input:

 
 
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
sample output:

 
 
Case 1: 14 1 4 Case 2: 7 1 6
分析:

基础DP,累计和s,大于零时开头结尾不变,小于零时重置开头结尾。

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
    //freopen("s.txt","r",stdin);
    int n,m=1;
    cin>>n;
    while(n--){
        int i,t,a[100000],sum=-10000,s=0,e,st=1,p=1;;
        cin>>t;
        for(i=1;i<=t;i++){
            cin>>a[i];
        }
        for(i=1;i<=t;i++){
            s+=a[i];
            if(s>sum){
                sum=s;
                e=i;
                st=p;
            }
            if(s<0){
                s=0;
                p=i+1;
            }
        }
        cout<<"Case "<<m<<":"<<endl;
        cout<<sum<<" "<<st<<" "<<e<<endl;
        if(n!=0)
            cout<<endl;
        m++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值