HDU 1069 Monkey and Banana(DP)


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
此题的关键在于要把每组数据展开为长方体三种不同的状态;
三个数任选一个作为高其余两个较大的作为长,较小的作为宽;
这样n组数据就展开出了3n个状态;
下面要保证DP出的结果是最优,就要证明相同形状的长方体相互叠加最多叠两层;
这个并不难证明;
之后按照长方体的长进行从大到小排序;
设f(i)为前i个中最高的;
之后得到状态转移方程:f(i)=max(f(j))+f(i);(其中j是1~i-1);
答案就是max(f(1),f(2),...,f(n));
#include<stdio.h>
#include<algorithm>
using namespace std;
struct rec
{
    int x;
    int y;
    int z;
}a[35];
struct rec2
{
    int dc;
    int dk;
    int h;
    int maxx;

}b[100];
bool cmp(rec2 aa,rec2 bb)
{
      if (aa.dc==bb.dc) return aa.dk>bb.dk;
      else return aa.dc>bb.dc;
}
int main()
{
    int n;
    int coutt=1;
    while (scanf("%d",&n)!=EOF)
    {
        if (n==0) break;
        for (int i=0;i<n;i++)
        {
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].z);
        }
        int countt=0;
        for (int i=0;i<n;i++)
        {
           b[countt].dc=max(a[i].x,a[i].y); b[countt].dk=min(a[i].y,a[i].x);b[countt].h=a[i].z;b[countt].maxx=b[countt].h; countt++;
           b[countt].dc=max(a[i].y,a[i].z); b[countt].dk=min(a[i].y,a[i].z);b[countt].h=a[i].x;b[countt].maxx=b[countt].h; countt++;
           b[countt].dc=max(a[i].z,a[i].x); b[countt].dk=min(a[i].x,a[i].z);b[countt].h=a[i].y;b[countt].maxx=b[countt].h; countt++;
        }
        sort(b,b+countt,cmp);
        for (int i=0;i<countt;i++)
        {
            for (int j=0;j<=i;j++)
            {
                if (b[i].dc<b[j].dc&&b[i].dk<b[j].dk)
                {
                    if (b[i].h+b[j].maxx>b[i].maxx)
                    {
                        b[i].maxx=b[i].h+b[j].maxx;
                    }
                }
            }
        }
        int maxn=-1;
        for (int i=0;i<countt;i++)
        {
            if (b[i].maxx>maxn) {maxn=b[i].maxx;}
        }
        printf("Case %d: maximum height = %d\n",coutt,maxn);
        coutt++;
    }



}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值