Uva1594 Ducci Sequence



A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1,a2,···,an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers: (a1,a2,···,an) → (|a1 −a2|,|a2 −a3|,···,|an −a1|) Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple: (8,11,2,7) → (3,9,5,1) → (6,4,4,2) → (2,0,2,4) → (2,2,2,2) → (0,0,0,0). The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps: (4,2,0,2,0) → (2,2,2,2,4) → (0,0,0,2,2) → (0,0,2,0,2) → (0,2,2,2,2) → (2,0,0,0,2) → (2,0,0,2,0) → (2,0,2,2,2) → (2,2,0,0,0) → (0,2,0,0,2) → (2,2,0,2,2) → (0,2,2,0,0) → (2,0,2,0,0) → (2,2,2,0,2) → (0,0,2,2,0) → (0,2,0,2,0) → (2,2,2,2,0) → (0,0,0,2,2) →··· Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.
Input
Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.
Output
Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.
Sample Input
4 4 8 11 2 7 5 4 2 0 2 0 7 0 0 0 0 0 0 0 6 1 2 3 1 2 3
Sample Output
ZERO

LOOP

ZERO

LOOP

设f(i,j)为第i次做|aj-a(j+1)%n|

由题已知最多1000次之后会出现循环或全部为零,所以只需要判断第f(1001,j)(其中j属于1~n)中有没有大于零的数,若有则是LOOP,否则是ZERO;

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[100];
int b[1005][100];
int n;
void f(int ii)
{
    for (int kk=0;kk<n;kk++)
    {
        b[0][kk]=a[kk];
    }

    for (int i=1;i<=ii;i++)
    {
       for (int j=0;j<n;j++)
       {
           b[i][j]=abs(b[i-1][j]-b[i-1][(j+1)%n]);
       }
    }



}
int main()
{
    int t;
    scanf("%d",&t);
    for (int k=0;k<t;k++)
    {
        scanf("%d",&n);
        for (int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }

        f(1001);
        int flag=1;
        for (int i=0;i<n;i++)
        {
            if (b[1001][i]>0) {flag=0; break;}
        }
        if (flag)
        {
            printf("ZERO\n");
        }
        else
        {
            printf("LOOP\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值