POJ 3468 A Simple Problem with Integers

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 96328 Accepted: 30033
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly–2007.11.25, Yang Yi
线段树+lazy标记 模板题

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
struct p{ll l,r,lz,val;}tree[400000];
char str[8];
void creatree(ll i,ll l,ll r)
{
    tree[i].r=r;tree[i].l=l;tree[i].lz=0;
    if (l==r){ll v;scanf("%I64d",&v);tree[i].val=v;return;}
    creatree(i*2,l,(l+r)/2);
    creatree(i*2+1,(l+r)/2+1,r);
    tree[i].val=tree[i*2].val+tree[i*2+1].val;
}
void updata(ll i,ll l,ll r,ll c)
{
    if (tree[i].r==r&&tree[i].l==l){tree[i].lz+=c;return;}
    tree[i].val+=c*(r-l+1);
    ll mid=(tree[i].l+tree[i].r)/2;
    if (r<=mid) {updata(i*2,l,r,c); return;}
    if (l>mid)  {updata(i*2+1,l,r,c);return;}
    if (l<=mid&&r>mid){updata(i*2,l,mid,c);updata(i*2+1,mid+1,r,c);}
}
ll _find(ll i,ll l,ll r)
{
    if (tree[i].r==r&&tree[i].l==l) return tree[i].val+tree[i].lz*(r-l+1);
    if (tree[i].lz!=0){tree[i*2].lz+=tree[i].lz;tree[i*2+1].lz+=tree[i].lz;tree[i].val+=(tree[i].r-tree[i].l+1)*tree[i].lz;tree[i].lz=0;}
    ll mid=(tree[i].l+tree[i].r)/2;
    if (r<=mid){return _find(i*2,l,r);}
    if (l>mid) {return _find(i*2+1,l,r);}
    if (l<=mid&&r>mid) return _find(i*2,l,mid)+_find(i*2+1,mid+1,r);
}
int main()
{

    ll n,m;scanf("%I64d%I64d",&n,&m);
    creatree(1,1,n);
    while (m--)
    {
        ll aa,bb,cc;
        scanf("%s",str);
        if (str[0]=='Q') {scanf("%I64d%I64d",&aa,&bb);printf("%I64d\n",_find(1,aa,bb));}
        else {scanf("%I64d%I64d%I64d",&aa,&bb,&cc);updata(1,aa,bb,cc);}
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值