hdu 1695 GCD(容斥原理)

GCD

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12106 Accepted Submission(s): 4576

Problem Description
Given 5 integers: a, b, c, d, k, you’re to find x in a…b, y in c…d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you’re only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

Output
For each test case, print the number of choices. Use the format in the example.

Sample Input
2
1 3 1 5 1
1 11014 1 14409 9

Sample Output
Case 1: 9
Case 2: 736427

问题可以转化为求[1,b/k] 与 [1,a/k] 中满足交换顺序后不同且互素的对数有多少个 。
可知对于素数p 在区间[1,n]中与其不互素的数有n/p个,所以利用容斥原理即可。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
using namespace std;
#define pb push_back
const int maxn = 1e5+100;
vector<int> v[maxn];
int vis[maxn];
void getpr()
{
  memset(vis,0,sizeof(vis));
  for (int i=0;i<maxn;i++) v[i].clear();
  for (int i=2;i<maxn;i+=2) v[i].pb(2);
  for (int i=3;i<maxn;i+=2)
  {
      if (!vis[i])
      {
          for (int j=i;j<maxn;j+=i)
          {
              vis[j]=1;
              v[j].pb(i);
          }
      }
  }
}
void solve(long long &ans,int sz,int w,int len)
{
    for (int i=1;i<(1<<sz);i++)
    {
        int cnt=0;
        long long x=1;
        for (int j=0;j<sz;j++)
        {
            if (i>>j&1)
            {
                cnt++;
                x*=v[w][j];
            }
        }
        if (cnt&1) ans-=len/x;
        else ans+=len/x;
    }

}
int main()
{
    getpr();
    int T;
    scanf("%d",&T);
    int cas=0;
    while (T--)
    {
        cas++;
        int a,b,c,d,k;
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if (k==0) {printf("Case %d: 0\n",cas);continue;}
        if (b>d) swap(b,d);
        b/=k;d/=k;
        long long  ans=0;
        for (int i=1;i<=d;i++)
        {
            int k=min(i,b);
            ans+=k;
            solve(ans,v[i].size(),i,k);
        }
        printf("Case %d: %lld\n",cas,ans);

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值