hdu 3709 Balanced Number(数位dp)

Balanced Number

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 6504 Accepted Submission(s): 3112

Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It’s your job
to calculate the number of balanced numbers in a given range [x, y].

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input
2
0 9
7604 24324

Sample Output
10
897
dp[pos][f][sum][limit][stat]
pos:当前位,
sum:力矩和
limit :前一位是否有限制
stat :是否含有前导零;

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <set>
#include <map>
#include <queue>
using namespace std;
#define LL long long
LL dp[20][20][2][4000][2];
int a[20];
LL dfs(int pos,int f,int sum,int limit,int stat){
    if (pos==-1){
        if (stat==1) return 0;
        return sum==0?1:0;
    }
    if (!limit&&dp[pos][f][limit][sum+2000][stat]!=-1) return dp[pos][f][limit][sum+2000][stat];
    int up=limit?a[pos]:9;
    LL ans=0;
    if (!stat){
        for (int i=0;i<=up;i++){
            ans+=dfs(pos-1,f,sum+(f-pos)*i,limit&&i==a[pos],0);
        }
    }else 
    {
       for (int i=0;i<=up;i++){
          if (i==0) ans+=dfs(pos-1,f,sum+(f-pos)*i,limit&&i==a[pos],1);
          else ans+=dfs(pos-1,f,sum+(f-pos)*i,limit&&i==a[pos],0);
       }
    }
    if (!limit) dp[pos][f][limit][sum+2000][stat]=ans;
    return ans;
}
LL solve(LL x){
    memset(dp,-1,sizeof(dp));
    if (x<0) return 0;
    int pos=0;
    while (x){
        a[pos++]=x%10;
        x/=10;
    }
    LL sum=0;
    for (int i=0;i<pos;i++) sum+=dfs(pos-1,i,0,1,1);
    return sum;
} 
int main(){
    int T;
    scanf("%d",&T);
    while (T--){
        LL a,b;
        scanf("%lld%lld",&a,&b);
        printf("%lld\n",solve(b)-solve(a-1)+(LL)(a==0));
    }

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值