Super Brain

Super Brain is a famous scientific reality and talent show aiming to find people with exceptional brainpower.

In one of the challenges, two integer sequences  and  of length  are given to the contestant. It's guaranteed that  and  hold for all , and there is exactly one integer in the first sequence which also appears in the second sequence. The contestant has to memorize the two sequences in a very short time, and find the integer which appears in both sequences correctly.

As a technical staff of the show, you are required to write a program and find out the correct integer.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer  (), indicating the length of the sequence.

The second line contains  integers  (), indicating the first sequence.

The third line contains  integers  (), indicating the second sequence.

It's guaranteed that  and  hold for all , and there is exactly one integer in the first sequence which also appears in the second sequence.

It's also guaranteed that the sum of  over all test cases will not exceed .

<h4< dd="">Output

For each test case output one line containing one integer, indicating the integer which appears in both sequences.

<h4< dd="">Sample Input
3
3
3 1 2
5 3 4
2
38324 14122
38323 14122
1
180310
180310
<h4< dd="">Sample Output
3
14122
180310

这道题我能说我wa了好几次嘛w(゚Д゚)w,老是超时......

#include<cstring>
#include<cstdio>
#include<iostream>
#include<cstdlib>
using namespace std;
int hash[1000001];
int main()
{
    int t,n;
    int x;
    scanf("%d",&t);
    while(t--)
    {
        memset(hash,0,sizeof(hash));
        scanf("%d",&n);
        for(int i=0;i<2*n;i++)
          {
              scanf("%d",&x);
              hash[x]++;
              if(hash[x]==2)
                  printf("%d\n",x);
          }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值