线段树之五--pku(2182)Lost Cows

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4375 Accepted: 2736

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

/*这样的题目唯一能确定的是最后一个数字是什么,比如输入a[1]...a[n],a[n] = x;则最后一个数字是x+1;
这个应该是显然的,因为前面有x个比自己小的数字在前面,所以“我"就是x+1;然后知道x排在最后了,就去更新一下树;
再求倒数第二个,比如a[n-1] = y (1。y<x 则去掉了一个比y+1还大的数(就是X)跟自己没有关系,所以倒数第二个数是y+1;
2如y>=x;则表明我这个位置的数肯定比x+1要大,但是比我小的一个数就是x+1排在我后面,所以我这个数是y+2。依次类推
*/
#include<iostream>
using namespace std;
struct tree
{
 int left,right;
 int len;//记录的是没有被确定排在最后面的且值[left,right]的个数;
}t[3*8000];
int dia[8010];
int ff[8010];
void maketree(int c,int l,int r)
{
 t[c].left = l;
 t[c].right = r;
 t[c].len = r - l + 1;
 if(l==r)
  return ;
 int mid = (r+l)>>1;
 maketree(2*c,l,mid);
 maketree(2*c+1,mid+1,r);
}
void del_update(int num,int c)
{
 if(t[c].right == t[c].left)
 {
  dia[++dia[0]] = t[c].right ;
  t[c].len = 0;
  return ;
 }
 int mid = (t[c].left + t[c].right)>>1;
 if(num<=t[2*c].len)
  del_update(num,c*2);
 else
  del_update(num - t[2*c].len,c*2+1);
 t[c].len --;
}
int main()
{
 int n,i;
 while(cin>>n)
 {
  for(i=2;i<=n;i++)
   scanf("%d",&ff[i]);
  ff[1] = 0;
  dia[0] = 0;//记录顺序用的;
  maketree(1,1,n);
  for(i=n;i>0;i--)
   del_update(ff[i]+1,1);
  for(i=dia[0];i>=1;i--)
   printf("%d/n",dia[i]);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值